Jump to content


Photo

php4 or php5


  • Please log in to reply
4 replies to this topic

#1 brown2005

brown2005
  • Members
  • PipPipPip
  • Advanced Member
  • 943 posts

Posted 17 August 2006 - 02:32 PM

in my website control panel it says php4 or php5... which one should i use?

#2 trq

trq
  • Staff Alumni
  • Advanced Member
  • 31,041 posts

Posted 17 August 2006 - 02:34 PM

Which one do you code in? 4 and 5 Really aren't all that different unless your into OOP, then you will want 5.

#3 brown2005

brown2005
  • Members
  • PipPipPip
  • Advanced Member
  • 943 posts

Posted 17 August 2006 - 02:36 PM

ill leave it on 4 then.. lol


#4 ToonMariner

ToonMariner
  • Members
  • PipPipPip
  • Advanced Member
  • 3,342 posts
  • LocationNewcastle upon Tyne, UK

Posted 17 August 2006 - 03:04 PM

for security reasons you shoudl always opt for the latest version on general release (not neccessarily the latest version that is!).

If your wensite has any OOP driven elements then stick with 4, update your scripts on a testing machine so they work in php5 then upgrade, if not upgrade to 5 straight away.
follow me on twitter @PHPsycho

#5 Jenk

Jenk
  • Members
  • PipPipPip
  • Advanced Member
  • 778 posts

Posted 17 August 2006 - 03:08 PM

php5 has other advances over php4.

use php5, php4 syntax is still valid.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users