Jump to content

Archived

This topic is now archived and is closed to further replies.

jwashburn

Drop Down Menus not working after upgrade

Recommended Posts

I have PHP 5.12 running on Windows 2003.  I have an application that reads from a database and presents a drop down list.  Nothing fancy.  I upgraded to 5.14 by stopping IIS and renaming my PHP directory to PHPOLD and then created a new PHP directory and dropped in the 5.14 files.  Nothing facny there either.  I edited my php.ini to fit my environment and fired up IIS.  Everything seems fine.  However the drop down menus dont work anymore.  The menu is still there and it is still populated with the correct information however when you choose it, the choice doesnt stay, it pops back to the default selection.

Any ideas?

Share this post


Link to post
Share on other sites
Drop down menus are client side... I dont understand what they might have to do with php. Maybe post some relevent code.

Share this post


Link to post
Share on other sites
[quote author=jwashburn link=topic=104648.msg417528#msg417528 date=1155833298]
Turns out I missed a line in the php.ini (of course)

register_long_arrays = On
[/quote]
You should use the newer superglobals $_POST, $_GET, etc rather than the old $HTTP_*_VARS when getting data from a form, url etc.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.