Jump to content

Archived

This topic is now archived and is closed to further replies.

Jimmy_T

Can't view live data

Recommended Posts

Hi, I was wondering if anyone can help me.

 

I have been following the getting started tutorial, and have had no problems until I get to the 'Developing a web application ' part.

 

I am trying to use PHP, and have Apache2, PHP and mySQL installed and working (I think) on my machine. But when I try to view the live data for the comments-view page, I get an error saying:

 

The testing server did not execute any of the scripts in your document! Possible explanations include:

1/ The testing server is not working. ( I think it is ???)

2/The testing server ignores files with the ".php" file extensions.

3/Your document does not contain any script

 

I am new to all this, but everything seems to be going smoothly until I try to view the live data. It appears to me as though the problem is in the setup in DW. If anyone has the solution to athis problem then please let me know.

 

Thanks in advance

James

Share this post


Link to post
Share on other sites

The possible cause is the root definition of your site. Without information about your systems file hierarchy its hard to pinpoint exactly where the problem lies but it does sound like a simple file path definition issue. If you mail karl302000@yahoo.com with details of dircrories for where apache is installed on your system and your local folder info I will send response will posssible solutions. It may not be entirely your fault as the dreamweaver definitions are not clear to everyone truying to understand them.

Share this post


Link to post
Share on other sites

Thank you very much for your offer to help!

 

I have apache2 installed under C:\Program Files\Apache Group\Apache2

 

for the root folder, I followed the tutorial in dreamweaver:

 

"Click the folder icon next to the Local Root Folder text box, then browse to and select the folder (inside the GettingStarted folder) that contains the PHP sample files. The folder should be as follows:

 

* C:\Documents and Setting\/your_user_name/\My

Documents\Sites-Local\GettingStarted\ 4-Develop\php (Windows)"

 

I have defined my remote folder as;

C:\Program Files\Apache Group\Apache2\htdocs\MySampleApp\

 

I hope this all makes sense, it's mostly taken from the setup for php in the getting started tutorial under the help menu in dreamweaver.

 

Again many thanks for your offer to help

James

 

Share this post


Link to post
Share on other sites

Marcromedia does a good job of describing how to map those directories in the section "Check the URL Prefix in the Site Definition" at http://www.macromedia.com/cfusion/knowledg...cfm?id=tn_16515.

 

The URL prefix refers to the Testing Server, not the remote server. It may depend on how you defined your (Local Server/Testing Server/Remote Server) setup when you installed Dreamweaver. Since, I chose to have all 3 servers, Dreamweaver tries to execute the comments-view.php page from the tutorial at my Testing Server, which is Apache installed on the same PC as Dreamweaver. Anyway, that link is a good read that refers to your previous discussion.

 

My interest is that I'm still getting the exact same error that you described. Google shows about 7 postings with this same problem, but no solutions. Only 7 postings, means that this problem is amazingly rare, or everyone else solved it so easily that they didn't bother to post about it.

 

I"m still looking for the answer. Some hints that I have evolved are:

1) When I display comments-view.php in a browser, I see a blank white page.

2) When I use the browser to view the source code, all it displays are two lonely body tags.

3) When I use Windows Notebook to open that exact same page on my hard drive, all the code is there.

4) Dreamweaver designs it's PHP to execute first, before the HTML. In Windows Notebook, I can see all the PHP code at the very top of the page before the other code.

5) Maybe ==> It is a parsing error, i.e. an error in the code that Dreamweaver put on the page. Since, PHP executes first and hangs up, the rest of the page is not displayed even though it is there.

 

Hey, I'm still guessing and looking. Good luck. Please post if you figure anything out.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.