Jump to content


Photo

Help with host permission thing please


  • Please log in to reply
4 replies to this topic

#1 Nomax5

Nomax5
  • Members
  • PipPipPip
  • Advanced Member
  • 62 posts
  • LocationYork England

Posted 23 August 2006 - 10:56 AM

Hi,

On one of my hosts the code below works but on the other I can an error, I am wondering if it’s a permissions thing.

It also works fine outputting to the browser but when I try to output the gif to a file I get this error:

<br />
<b>Warning</b>:  imagegif(): Unable to open 'images/canvasfile.gif' for writing in <b>/nfsn/content/blinkingphoto/htdocs/test.php</b> on line <b>4</b><br />

this is the code any ideas?

<?php
	 header ("Content-type: image/gif");
	 $canvas = imagecreatefromgif("images/bird1.gif");	 
	 imagegif($canvas,"images/canvasfile.gif");
	 imageDestroy($canvas);
	 echo "file created";
?>

I am not very familiar with setting up stuff like this.

#2 SammyP

SammyP
  • Members
  • PipPipPip
  • Advanced Member
  • 58 posts
  • LocationLondon

Posted 23 August 2006 - 11:31 AM

Is it to do with the folder permissions in your respective 'images' directories?

I always forget to change them so I can create thumbnails, and have set up code to remind me now.

Sam.

If this has solved your problem, a quick 'Thanks' is appreciated, but marking the thread as 'Solved' is better - it saves a lot of time.

Sam.

#3 Nomax5

Nomax5
  • Members
  • PipPipPip
  • Advanced Member
  • 62 posts
  • LocationYork England

Posted 23 August 2006 - 11:50 AM

my images folder is set to 755 on both hosts

#4 SammyP

SammyP
  • Members
  • PipPipPip
  • Advanced Member
  • 58 posts
  • LocationLondon

Posted 23 August 2006 - 12:44 PM

Darn.

Not much more I can think of. Could be something to do with gifs? Some hosts don't load the software for those. I think there is some licensing issue. Probably way off here. Can you create a text file on both?

Sorry not to be of any more help here.




If this has solved your problem, a quick 'Thanks' is appreciated, but marking the thread as 'Solved' is better - it saves a lot of time.

Sam.

#5 Nomax5

Nomax5
  • Members
  • PipPipPip
  • Advanced Member
  • 62 posts
  • LocationYork England

Posted 23 August 2006 - 01:02 PM

I contacted my host and it suddenly started working I guess it was a set up thing
or something so newbie they didn't want to embarress me lol.

thanks for your help SammyP  much appreciated.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users