Jump to content


Photo

403 Error


  • Please log in to reply
No replies to this topic

#1 OldManRiver

OldManRiver
  • Members
  • PipPipPip
  • Advanced Member
  • 88 posts

Posted 24 August 2006 - 06:36 PM

Been troubleshooting my WAMP on W2k Pro and Apache was working, but PHP was not.  Found I had not defined the "doc_root" in the php.ini file, so changed it.

Now I get 403 errors even on the root localhost.

httpd.conf reads:
ServerRoot "D:/Program Files/Apache/Apache2"
Listen 80
ServerName localhost
DirectoryIndex index.htm index.html index.html.var index.shtml index.php index.phml index.cfm index.cfml
DocumentRoot "D:/Program Files/Apache/Apache2/htdocs"
<Directory>
  Options FollowSymLinks
  AllowOverride None
</Directory>
UserDir "E:/Nyle's/Business Projects/Projects (External)"
# Config for PHP
LoadModule php5_module "D:/Program Files/PHP/php5apache2.dll"
AddType application/x-httpd-php .php
PHPIniDir "D:/Program Files/PHP"
Action application/x-httpd-php "/php/php-cgi.exe"
ScriptAlias /php/ "D:/Program Files/PHP/"
AddHandler php-script .php .phml
AddHandler php .php .phml
<Directory "D:/Program Files/PHP">
  Options
  Allow from all
  Order allow,deny
  AllowOverride None
</Directory>

php.ini reads:
;include_path = ".;c:\php\includes"
doc_root = "D:/Program Files/Apache/Apache2/htdocs"
user_dir =
extension_dir = "./"

What do I need to look for or correct?  Do I need to match the user directories?

Install instructions at:

http://www.devarticl...nder-Windows/4/

say I need to copy files into the Apache root directory, this is written for version 4 not 5.  Are these still good instructions?  What would change on these for version 5?

OMR




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users