Jump to content

Archived

This topic is now archived and is closed to further replies.

api

Problem with url in mail content

Recommended Posts

I want to sent a webpage as the content of mail.
I got the source code of the webpage and send it as the mail content of the PHP mail function.
And when i check my inbox, i get all the content(text, alignment ans so on) fine EXPECT that it does not show the images, coz the image urls are replaced by some other data.

Want guidance, Can anyone tell why is the url getting changed???

Thx in advance.

Share this post


Link to post
Share on other sites
been my experience that most image problems in emails are due to your email settings. however, you might also want to make sure that your code is using full url addresses, not just relative.

Share this post


Link to post
Share on other sites
hi

Thx for replying.

my image hav the full url, like "http://mysite.com/images/logo.jpg" when echo the content before sending it as email content.
But when ever it reaches my inbox, the url get distorted. dunno why???
In yahoo inbox, few of my image url are shown as below, whereas my urls were as simple as above.

<img src="http://us.i1.yimg.com/us.yimg.com/i/us/pim/r/medici/all/bt_dd_2.gif" alt="Calendar shortcuts">

<img src='http://us.i1.yimg.com/us.yimg.com/i/us/pim/el/spc_eee1.gif' border='0'>

plz help

Share this post


Link to post
Share on other sites
yahoo inbox can not hold out 'HTML'

try to set your content wiht HTML when you sent mail

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.