Jump to content


Photo

User dir public html does not work. Permission denied


  • Please log in to reply
1 reply to this topic

#1 thusi02

thusi02
  • New Members
  • Pip
  • Newbie
  • 6 posts

Posted 25 August 2006 - 07:08 PM

Hello All,
I have just installed Red Hat ES4 with RH's distribution of apache. Default install and enabled the userdir and the public_html dir. The following is my configuration for httpd.conf:

<IfModule mod_userdir.c>
#
# UserDir is disabled by default since it can confirm the presence
# of a username on the system (depending on home directory
# permissions).
#
#UserDir enable all

#
# To enable requests to /~user/ to serve the user's public_html
# directory, remove the "UserDir disable" line above, and uncomment
# the following line instead:
#
UserDir public_html

</IfModule>
#
# Control access to UserDir directories. The following is an example
# for a site where these directories are restricted to read-only.
#
<Directory /home/*/public_html>
AllowOverride All
Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec ExecCGI
</Directory>

Why am I getting Permission denied (403 error) when trying to go to http://domain/~user/index.html

Any help?

Cheers,
Thusi
http://letstalkcoding.com

#2 oldmanice

oldmanice
  • Members
  • PipPipPip
  • Advanced Member
  • 134 posts
  • LocationIn Your Garden At Night

Posted 04 September 2006 - 01:16 AM

The <Directory /home/*/public_html>  bit is wrong it should be either DirectoryIndex header.html or DirectoryIndex index.html
Join my Froums www.phpbbplanet.com/darkwinter




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users