Jump to content


Photo

FATAL ERROR: register_globals is disabled in php.ini, please enable it!


  • Please log in to reply
2 replies to this topic

#1 swflaman

swflaman
  • New Members
  • Pip
  • Newbie
  • 1 posts

Posted 25 August 2006 - 08:06 PM

I can't find a php.ini file anywhere in my site! It is an oscommerce site reinstalled from a backup on a new server since my old server went under without notice. PLEASE HELP!
thanks

#2 Barand

Barand
  • Moderators
  • Sen . ( ile || sei )
  • 18,017 posts

Posted 25 August 2006 - 08:23 PM

phpinfo() will give you its location.

And if your software requires register globals enabled, change your software.
If you are still using mysql_ functions, STOP! Use mysqli_ or PDO. The longer you leave it the more you will have to rewrite.

Donations gratefully received






moon.png

|baaGrid| easy data tables - and more
|baaChart| easy line, column and pie charts

#3 kenrbnsn

kenrbnsn
  • Staff Alumni
  • Advanced Member
  • 8,235 posts
  • LocationHillsborough, NJ, USA

Posted 25 August 2006 - 08:24 PM

Create a script with the following line in it
<?php phpinfo(); ?>
upload it to your server, and invoke it. The output will tell you where php.ini is.

Ken




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users