Jump to content

Archived

This topic is now archived and is closed to further replies.

miseleigh

Upgrading Apache

Recommended Posts

I'm trying to upgrade Apache 2.0.44 to 2.0.59.  So far it looks like all I have to do is save my current .conf files, delete the old version, and install the new one.  Is there anything I'm missing?  Any help would be greatly appreciated.  Thanks!

Share this post


Link to post
Share on other sites
I usually let the new one overwrite the existing, but I guess it doesn't matter as long as you have everything backed up.

Share this post


Link to post
Share on other sites
Yeah, that would do it too :)

Also, can anyone tell me if there is a build out there for 2.0.59 that includes SSL (on a windows platform)?  I can't seem to find one, and I have no wish to build it myself (assuming I even can).

Share this post


Link to post
Share on other sites
Well, I'm getting somewhere, anyways...

I can get Apache started, running 2.0.59, but now I'm encountering another small problem.

When trying to start, Apache says: [quote]Unknown(): Unable to load dynamic library 'C:/OpenSA/Apache2/php4/modules\php_openssl.dll' - The operating system cannot run %1.[/quote]
Then I hit ok, and it comes up again, and I hit ok again, and then Apache runs.  Anybody know what's causing that error and how to fix it?  The OS is Windos, it's OpenSSL v0.9.8, PHP 4.3.0.  Thanks!

Share this post


Link to post
Share on other sites
Look at the slashes: [tt]C:/OpenSA/Apache2/php4/modules\php_openssl.dll[/tt].

Share this post


Link to post
Share on other sites
You need to configure the extension_dir directive in the php.ini to sort that out.

Share this post


Link to post
Share on other sites
Alright, so after changing "extension_dir = C:/OpenSA/Apache2/php4/modules" to "extension_dir = C:\OpenSA\Apache2\php4\modules" in php.ini, my error changes slightly:
[quote]Unknown(): Unable to load dynamic library 'C:\OpenSA\Apache2\php4\modules\php_openssl.dll' - The operating system cannot run %1.[/quote]
I don't think the slashes were the problem.  And yes, that module is in that directory.

I should note that the .conf files I'm using for Apache 2.0.59 are the same ones I used for 2.0.44 - are there any subversion-specific things I should change?  I didn't find any, but I'm good at missing that sort of thing.

Thanks!

Share this post


Link to post
Share on other sites
Where is you php extensions located to, they should in the ext(ensions) folder that came with php.

Share this post


Link to post
Share on other sites
All the php stuff is in C:\OpenSA\Apache2\php4, with all php .dll files in \modules.  I believe that's the way it installed - OpenSA came as a packet.  There are a number of other .dll files in that same folder that get called in php.ini without causing any errors when Apache starts up.

Share this post


Link to post
Share on other sites
Oh your using an all-in-one installer which installs Apache and PHP etc. Lloks like openssl is trying to run a command which Windows cannot run. Do you need openssl. If you dont open up the php.ini and add a semi-colon infront of extension=php_openssl.dll

Save php.ini, restart Apache.

Share this post


Link to post
Share on other sites
I would have done that a while ago if I didn't need openssl :P

Apparently openssl.dll is dependent upon msvcr80.dll, which I don't have.  Going to find it...

Share this post


Link to post
Share on other sites
Alright, now I have all three dependencies (ssleay32.dll, libeay32.dll, msvcr80.dll) in both my windows/system32 folder and apache2/bin (as suggested [url=http://www.sitepoint.com/forums/showthread.php?s=b7af6ad03c641f36b15cdce808d14d49&t=203521&page=2&pp=25]here[/url]), and still have the same problem.

Btw, in case anybody finds this hread with similar issues, .ddls can be found [url=http://www.dll-files.com/dllindex/index.shtml]here[/url].

Share this post


Link to post
Share on other sites
It probably comes with the openssl package. Download [url=http://www.openssl.org/]openSSL Here[/url]. php_openssl requires this package to be installed.

Also prehaps having a read of [url=http://uk2.php.net/manual/en/ref.openssl.php]this page[/url] on enabling openssl.

Share this post


Link to post
Share on other sites
Well, SSL seems to be working just fine for PHP without that pesky .dll, so solution = comment it out in php.ini.  Odd how that works.  I had thought that I needed it, but apparently not.

Thanks for all your help, wildteen88.

Share this post


Link to post
Share on other sites
You could have just simply moved your files to your documents and draged it back in when youve got the new apache.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.