Jump to content

Archived

This topic is now archived and is closed to further replies.

muffin100

Installation problem

Recommended Posts

Please Help!!!

Sorry to say, I have no idea what I did wrong, but after I installed PHP 4.3.4 with apache 2.0.53, the PHP pages don't show up at all. They just show up like a text file. Just like this:

[b]<?
phpinfo();
?>[/b]

I have installed PHP as normally using a script:

[b]./configure --prefix=/usr/local/php \
--mandir=/usr/local/src/man \
--with-mysql=/usr/local/mysql \
--with-apxs2=/usr/local/apache2/bin/apxs[/b]

then make and make install
and I have also configured the httpd.conf with:

[b]LoadModule
php4_module /usr/local/apache2/modules/libphp4.so[/b]

&

[b]AddType application/x-httpd-php .php .php3[/b]

Is there something wrong with my configuration or my installation?

Share this post


Link to post
Share on other sites
Does this work?

[code]<?php
phpinfo();
?>[/code]

If so, then 'short tags' are not enabled in your set-up.

Share this post


Link to post
Share on other sites
OMG... thank you for this post.


I've been a PHP Guru for since 2001... and I just 24hours trying to get it to work on W2K, which normally I use Linux.  However the first time I've use 5.1.x  and I didn't realize that the directive  short_tag_open = off


I was pulling my nose hair out.

This is what you need to change in the php.ini  in order to make  <? echo phpinfo() ?> work..    otherwise you have to u se <?php  echo phpinfo(); ?>

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.