Jump to content


Photo

No session support in my php installation!?


  • Please log in to reply
4 replies to this topic

#1 mawkish

mawkish
  • New Members
  • Pip
  • Newbie
  • 3 posts
  • LocationStockholm

Posted 29 August 2006 - 09:53 PM

I have a problem with my php5/apache2 installation on Debian Linux. I don't seem to have session support. I get: "Fatal error: Call to undefined function session_name() in..." when loading a page containing the session_name() function.

If I had session support I guess it would be visible in phpinfo, but it's not (see http://www.magnus.ws/phpinfo-copy.htm).
Session support are supposed to be enabled in php by default. But I think you can compile without it if you want. I didn't do anything like that, I just installed the Debian packages like this:
# apt-get install php5 libapache2-mod-php5 php5-curl php5-gd

Did I miss to install something or were those packages already built without session support?
Or did I just miss to enable something?  Plz help ???

www.magnus.ws

#2 Corona4456

Corona4456
  • Members
  • PipPipPip
  • Advanced Member
  • 244 posts
  • LocationEl Paso, TX

Posted 29 August 2006 - 10:01 PM

Hmm... that's odd.  According to the php site:

Session support is enabled in PHP by default


What distro of linux are you using?
What is the CoronaMatrix?

#3 mawkish

mawkish
  • New Members
  • Pip
  • Newbie
  • 3 posts
  • LocationStockholm

Posted 29 August 2006 - 10:06 PM

I use Debian Sarge.
www.magnus.ws

#4 Corona4456

Corona4456
  • Members
  • PipPipPip
  • Advanced Member
  • 244 posts
  • LocationEl Paso, TX

Posted 29 August 2006 - 10:23 PM

Yeah this may be more of a debian linux support question than PHP... since it should be enabled by default then they may have disabled it somehow but who knows... maybe you can go to their support forum and find a better answer :).
What is the CoronaMatrix?

#5 mawkish

mawkish
  • New Members
  • Pip
  • Newbie
  • 3 posts
  • LocationStockholm

Posted 29 August 2006 - 10:50 PM

Yeah, with a heavy heart I will turn to the Linux forums, damn that Tux...
Anyway, from this post I learnt that I didn't miss any obvious php setting, right.
Thanks!

Maybe just those installation packages were weired --> reinstall, with other servers in my /etc/apt/source.list.
www.magnus.ws




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users