Jump to content


Photo

problems with mail()


  • Please log in to reply
No replies to this topic

#1 chriscloyd

chriscloyd
  • Members
  • PipPipPip
  • Advanced Member
  • 489 posts
  • LocationArizona

Posted 30 August 2006 - 05:07 PM

i have a script where i can deny a users application

heres the mailing script
if(isset($message)){
			$message = addslashes(htmlspecialchars($message));
			$email = $email;
			$subject = $subject;
			$headers1 = "MIME-Version: 1.0\r\n";
			$headers1 .= "Content-type: text/html; charset=iso-8859-1\r\n";
			$headers1 .= "From: Application@conception-host.com\r\n";

				if(!mail('$email','$subject','$message','$headers1')){
					echo 'Could Not Send Email, Did not Delete Application';
					} else {
					mysql_query("DELETE FROM app WHERE email='$email'") 
					or die(mysql_error()); 
					echo '<br><br><br>Email Has Been Sent And Application Has Been Deleted';
				}
			} else {
			echo '<form name="form1" method="post" action="?function=deny">
			  <table width="332" border="0" cellspacing="5" cellpadding="0">
				<tr>
				  <td width="73">Email</td>
				  <td width="244">'.$_GET['email'].'
				  <input name="email" type="hidden" id="email" value="'.$_GET['email'].'"></td>
				</tr>
				<tr>
				  <td>Subject</td>
				  <td>Application Review 
				  <input name="subject" type="hidden" id="subject" value="Application Review"></td>
				</tr>
				<tr>
				  <td valign="top"><p>Message<br>
					  <span class="var"><strong>Default<br>
					Message
					  </strong></span></p>        </td>
				  <td><textarea name="message" cols="30" rows="5" class="inputs">Application Review
-----------------------------------------
			
To Whom This May Concern,

I regret to inform you that you failed your application
process.  It might not be that you failed exactly
but, we might have filled up that position.  If you would 
like another chance feel free to send another application
but, write more infomation about your self and give more
expirence.
			
Application Procceser
Conception-Host.com
#CHOST</textarea></td>
				</tr>
				<tr>
				  <td>&nbsp;</td>
				  <td><input type="submit" name="Submit" value="Send"></td>
				</tr>
			  </table>
			</form>';
			}

but it says the echo that email had been sent but its not sending and i get this wierd error above that message that says
/var/chroot/home/content/c/h/r/chriscloyd/dead.letter... Saved message in /var/chroot/home/content/c/h/r/chriscloyd/dead.letter
44 bugs in my java code
44 bugs in my java code
Fix 1 bug, and complie again
122 bugs in my java code




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users