Jump to content


Photo

createing zip files with php


  • Please log in to reply
3 replies to this topic

#1 tomfmason

tomfmason
  • Staff Alumni
  • Advanced Member
  • 1,696 posts
  • Locationstealing your wifi

Posted 31 August 2006 - 07:14 AM

I thought that phpfreaks had a tutorial for this but I am unable to find it. Does anyone else know the link?

Traveling East in search of instruction, and West to propagate the knowledge I have had gained.

current projects: pokersource

My Blog | My Pastebin | PHP Validation class | Backtrack linux


#2 Daniel0

Daniel0
  • Staff Alumni
  • Advanced Member
  • 11,956 posts

Posted 31 August 2006 - 07:17 AM

http://php.net/zip if you got PHP5.1 or later.

#3 tomfmason

tomfmason
  • Staff Alumni
  • Advanced Member
  • 1,696 posts
  • Locationstealing your wifi

Posted 31 August 2006 - 08:08 AM

I have PHP5.0.5 . I think that I need a tutorial. Because I am developing a script that will be used by other people that may have older versions of php. I could have sworn that phpfreaks had a tutorial for this.

Traveling East in search of instruction, and West to propagate the knowledge I have had gained.

current projects: pokersource

My Blog | My Pastebin | PHP Validation class | Backtrack linux


#4 Orio

Orio
  • Staff Alumni
  • Advanced Member
  • 2,491 posts

Posted 31 August 2006 - 08:29 AM

Quoted from www.php.net/zip:

PHP 4 Bundled
The initial version is bundled in PHP 4 and is available in PECL as version 1.0, see http://pecl.php.net/package/zip. It can only read Zip Archives.

PECL and PHP 5.2 or later
The newest version is bundled in PHP 5.2.0 or later and available in PECL, as version 1.1.0 or later. It does not require any external library. It can read and write Zip archives when used with PHP 5.1 or later and can only read them when used with PHP4.


That means- if you only want to be able to read zip files (being uploaded lets say), you can do it if you have PHP4 are greater. But if you want also to create zip archives, you'll need PHP5.1 or later.

Orio.

EDIT- Just saw the title of the topic, so I guess you need PHP5.1 or greater for that.
Think you're smarty?

(Gone until 20 to November)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users