Jump to content

Archived

This topic is now archived and is closed to further replies.

DaVuLf

PhpMyAdmin Login?

Recommended Posts

Hey there. I just installed phpMyAdmin on my server, but it isn't asking for login information. Clearly this is an issue since anyone can access my database online.

How do I modify this?

Thanks,
DaVuLf

Share this post


Link to post
Share on other sites
do u have a log in for connecting to the database
for example if its localhost, most is
Username: root
Password: root

Share this post


Link to post
Share on other sites
You;ll want look for the config.inc.php file in the root of the phpMyAdmin folder and look for the following:
[code]$cfg['Servers'][$i]['auth_type']    = 'config';[/code]

Change conf to http. Now goto access phpMyAdmin again. You should now get a promt requesting authentication.

If you cannot find config.inc.php. Goto libaries and find config.defualt.php, copy that to the root of the phpmyadmin folder and rename that file to config.inc.php, now follow the instructions above.

Share this post


Link to post
Share on other sites
Thanks. I tried this and now it is prompting for password. Unfortunately, it isn't recognizing the proper inputs as correct. See here:

http://www.briancomeau.net/phpMyAdminbak/

I want it to show up like that. The HTTP prompt is a javascript popup it looks like.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.