Jump to content

Archived

This topic is now archived and is closed to further replies.

nloding

LAMP issues in SUSE 10.1

Recommended Posts

OK, I know NOTHING about Linux (OK, I know just enough to install it).  I want to just set up a simple web server with PHP and MySQL support using Apache2.  Should be simple enough.  So I tried ...

I installed Apache2 following the directions on the site, and that worked beautifully.  So then I downloaded the latest php tarball (5.1.6) and attempted to install that.  I opened a terminal and did "su root" to switch to root, then did:

gzip -d php-5.1.6.tar.gz
tar xvf php-5.1.6.tar
cd php-5.1.6
./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql

Errored out on finding "libxml2" -- so I found that online, downloaded, and installed the same way I did Apache2 ... worked!  So then I tried the same commands above, and it errored out in finding MySQL ... well duh, I didn't install that yet.  So here's my question:

If i take off the --with-mysql switch, do I need to do something after installing PHP to get it work with MySQL?  Or should I install MySQL first?  Which is another issue -- I tried that, but it wouldn't let me run ./configure because it said it didn't need that and just worked!  So do I just un-tar it to /user/bin/mysql5 or something?

AAAHHHH!  Linux is so foreign!

Thanks!

--Nathan

Share this post


Link to post
Share on other sites
Suse should be just as simple to use as windows. There is a package manager called yast, Apache, php and Mysql should all be easily installed via it.

Share this post


Link to post
Share on other sites
check yast if libxml2 is installed in not you can download the libxml2 source then do this

tar xzvf libxml2....
./confogure --prefix=/usr/local/

and then add this to your php configure --with-libxml2=/usr/local

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.