Jump to content

Archived

This topic is now archived and is closed to further replies.

GodsDsipl

HELP: Please CHMOD to 0777

Recommended Posts

I am trying to install IPB 2.1 on my server but I get the following error...

Warning! The following errors must be rectified before continuing!

·Cannot write to the file '../conf_global.php'. Please CHMOD to 0777.

·Cannot write to the file '../cache'. Please CHMOD to 0777.

·Cannot write to the file '../cache/lang_cache/'. Please CHMOD to 0777.

·Cannot write to the file '../cache/skin_cache/'. Please CHMOD to 0777.

[b]How do I CHMOD ??? [/b]  ???

Share this post


Link to post
Share on other sites
u need to go in to yr control panel and
Cannot write to the file '../conf_global.php'. Please CHMOD to 0777. change permission on this file

·Cannot write to the file '../cache'. Please CHMOD to 0777.
this folder
·Cannot write to the file '../cache/lang_cache/'. Please CHMOD to 0777.this folder

·Cannot write to the file '../cache/skin_cache/'. Please CHMOD to 0777 and this folder

Share this post


Link to post
Share on other sites
Go to the top of you're install file and put this

[code]
$permit = 0777;
chmod("../conf_global.php", $permit);
chmod("../cache", $permit);
chmod("../cache/lang_cache/", $permit);
chmod("../cache/skin_cache/", $permit);
[/code]

when you're done installing
make a [size=10pt][b]copy[/b][/size] of you're install.php file
erase everything in it
and replace with this

[code]
$permit = 0644;
chmod("../conf_global.php", $permit);
chmod("../cache", $permit);
chmod("../cache/lang_cache/", $permit);
chmod("../cache/skin_cache/", $permit);
echo "Permissions Changed Back to " . $permit;
[/code]
and then of course open that copy in your browser

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.