Jump to content

Archived

This topic is now archived and is closed to further replies.

ev66

Syntax help

Recommended Posts

In the code below im trying to echo an image using a variable $a but cant get it to work.It works if i use the image name, but cant get it to work using the variable, any ideas please ?
Thanks

[color=green]THIS DOESNT WORK[/color]
[color=red]<?php $a = "ad_ink-spot.gif"; ?>[/color]
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Untitled Document</title>
</head>

<body>
<p></p>
<p>&nbsp;</p>
<p>[color=red]<?php echo '<a href=' . $_SERVER['PHP_SELF'] . '><img src=images/' . $a . 'width=200 height=121 border=0 /a>'; ?>[/color]&nbsp;</p>
</body>
</html>

[color=green]THIS DOES WORK[/color]
[color=red]<?php $a = "ad_ink-spot.gif"; ?>[/color]
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Untitled Document</title>
</head>

<body>
<p></p>
<p>&nbsp;</p>
<p>[color=red]<?php echo '<a href=' . $_SERVER['PHP_SELF'] . '><img src=images/ad_ink-spot.gif width=200 height=121 border=0 /a>'; ?>[/color]&nbsp;</p>
</body>
</html>

Share this post


Link to post
Share on other sites
[code=php:0]
<?php echo '<a href="' . $_SERVER['PHP_SELF'] . '"><img src="images/' . $a . '" width="200" height="121" border="0"></a>'; ?>
[/code]

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.