Jump to content


Photo

Dreamweaver MySQL Connection


  • Please log in to reply
11 replies to this topic

#1 goingcrazy

goingcrazy
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 03 September 2004 - 05:29 PM

no idea what's going wrong...
i was following the dreamweaver tutorial for php but i just can't get the connection working.
i've read every help i could find but nothing helps.

i'm running:
Dreamweaver MX 2004
IIS v5.1
PHP v5.0.1
MySQL v4.0.20

any ideas?

#2 olaf

olaf
  • Members
  • Pip
  • Newbie
  • 2 posts
  • LocationThe Netherlands

Posted 03 September 2004 - 09:49 PM

is the connection file created by dreamweaver? If yes show it here...
Later !

Olaf

Free PHP classes :: ... need a website template?

#3 goingcrazy

goingcrazy
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 04 September 2004 - 01:24 AM

not sure what you mean by a connection file...

#4 andy

andy
  • Members
  • Pip
  • Newbie
  • 5 posts
  • Locationlondon

Posted 09 September 2004 - 01:10 PM

It may be the same problem I used to get.

In your testing server window in the site setup, make sure that you have simply http://www.yoursite.com as dreamweaver puts in something like http://ftp.yoursite.com/web or whatever your directory is (htdocs, www etc)

This one drove me mad for a while

Andy

#5 upit

upit
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 09 September 2004 - 06:18 PM

yeah i got the same problem that you have. But Once i made mysql connections succesfull. That happen when I remove IIS then reinstall it.But its not always succes.I guess the file that dreamweaver created is the source of the problem. Sometimes after the unidentified error message occured the another error message occurs.It says the file is being used by another program but i dont know which program use that file. any one have solutions ? :unsure:

#6 haavarl

haavarl
  • New Members
  • Pip
  • Newbie
  • 1 posts

Posted 09 November 2004 - 08:23 AM

Same problem happened to me. I followed Dreamweaver's help file on installing PHP and MySql, and the "Unidentified Error" thingie showed on connection.

I found this solution:
1) When I installed php, I downloaded the "Windows Installer" package. That actually didn't come with support for MySQL (oh, this took some time to figure allright ...)
2) What I needed was the files php_mysql.dll and libmysql.dll.
3) I downloaded the full php package, and copied out the dll files to \winnt\system32.
4) Uncomment the line extension=php_mysql.dll in php.ini.
5) Voilá, the test connection worked.

HTH,
haavarl

#7 Jehozadak

Jehozadak
  • New Members
  • Pip
  • Newbie
  • 1 posts

Posted 26 November 2004 - 02:19 AM

I have a similar problem with Dreamweaver, I downloaded PHP 5.0.2.2 and MySQL Server 4.1. They have been installed in a Windows Server 2003.

When i tried to connect from another computer in the local network to PHP, it works normally, it gave some troubles with ASP pages, but nothing to became crazy, it just change my MS Access databases permission. Well, now i can connect to PHP, but it wont let me connect to MySQL database. I can connect MySQl from ASP pages with MyODBC without problems, but my boss want to migrate his web page to PHP, any suggests???

Please, i have lost many brain cell with this!!!!!!!!! :blink:

#8 neongtr

neongtr
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 10 January 2005 - 05:39 AM


i have the sample problem too

I read and read many forum and tried out varies suggestions and none of them work.

I am thinking may be design the php page with dmx and hand code the connection bit.



#9 neongtr

neongtr
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 12 January 2005 - 05:28 AM


I use WAMP package and it works for me...

connect up straight away



#10 newbie1

newbie1
  • New Members
  • Pip
  • Newbie
  • 3 posts

Posted 04 February 2005 - 03:28 PM

SUMMARIZING 4 TROUBLESHOOTING POINTS FOR MYSQL CONNECTION

1) In Dreamweaver, go to Sites/Manage Sites/Advanced, in “Testing Server,” be sure to configure URL prefix: http://localhost/ .... See Check the URL Prefix in the Site Definition at Macromedia.com. (Note that the URL prefix does not always need to point to http://localhost/. Right now, we are just using localhost as the troubleshooting web site. The important thing is for “URL prefix” to point to the document root address of whichever testing web site you are connecting to.)

2) Make sure that the MySql extension is activated in php.ini. Take the ; off the left side of the line in order to activate: extension=php_mysql.dll

3) Make sure that extension_dir = “c:\php\ext” is activated in php.ini, and that it points to the correct directory where php_mysql.dll is located.
For PHP5: extension_dir = “c:\php\ext”
For PHP4: extension_dir = “c:\php" Use this if you followed PHP4 installation instructions and copied all the extensions from c:\php\extensions to c:\php.

4) Make sure that PHP is working in Apache server. Does browsing to your http://localhost/phpinfo.php page display PHP graphics and data?

BLANK PAGES AND ERROR CODES IN DREAMWEAVER

The Dreamweaver Tutorial has you create PHP code on two pages: comments-view.php and comments-add.php. The problem is that after you complete the tutorial instructions, both pages display as blank pages in your Internet browser.
If you’re working on those pages in Dreamweaver, when you click on “Live Data View” you get the following error code:

The testing server did not execute any of the scripts in your document. Possible explanations include:
1) The testing server is not running.
2) The testing server ignores files with the ".php" file extension.
3) Your document does not contain any scripts.

This is caused by a parsing problem in PHP, i.e the PHP code hangs up and your Apache server gives you a blank page. The solution is to make a change in the php.ini file. Change short_open_tag = on to make it read: short_open_tag = off

Good luck. I hope this helps.

REFERENCE: http://www.thriftypl...php___apac.html

#11 adarhol

adarhol
  • New Members
  • Pip
  • Newbie
  • 1 posts

Posted 28 June 2005 - 03:35 PM

everything is correct php and my sql works but when i tried to connect dreamweaver with mysql i can't, i got this message :

error undefined....

dreamweaver create a connection : here is the file:

[code=auto:0]
<?php
# FileName="Connection_php_mysql.htm"
# Type="MYSQL"
# HTTP="true"
$hostname_dbconnection = "localhost";
$database_dbconnection = "name_database";
$username_dbconnection = "user";
$password_dbconnection = "password";
$dbconnection = mysql_pconnect($hostname_dbconnection, $username_dbconnection, $password_dbconnection) or trigger_error(mysql_error(),E_USER_ERROR);
?>
[code=auto:0]

can you help me? I also modified the php.eni :

[code=auto:0]
extension_dir = “d:\php\ext”
[code=auto:0]

thanks, i'm getting crazy.....


#12 ma3743

ma3743
  • New Members
  • Pip
  • Newbie
  • 5 posts

Posted 21 July 2005 - 01:59 PM

Hi
I’ve found a solution for this problem
When you want to connect to your database be shore you are online.
In Internet explorer go to file menu and unchecked work offline.
When my Internet explorer is in offline mode I receive "An unidentified error has occured"







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users