Jump to content


Photo

Unable to access outside local machine


  • Please log in to reply
8 replies to this topic

#1 levi_kim

levi_kim
  • New Members
  • Pip
  • Newbie
  • 4 posts

Posted 03 September 2006 - 06:12 AM

I'm trying to run a http webserver on my home pc.  I can access my pages from the machine itself, but not other machines such as work, friends houses, etc. 

Oddly, I *can* access the pages from other machines if I do so through a proxy service like proxify.com.  I'm new to Apache and was hoping one of the experts out there had some ideas what may be causing the problem. 

Some general info:
  • I'm Running Windows XP Professional
  • I'm using Apache 2.2.3
  • My ISP (cox.net) blocks port 80.  I'm redirecting to port 8888.
  • I don't have a router, I'm plugged directly into my cable modem.
  • I believe my windows firewall is set up correctly, and the problem persisted when I tested with the firewall turned completely off.
  • The HTML error received is usually 404, or a Timed Out error.
  • Again, I can view the pages from http://localhost:8888 or from any machine via a proxy server.

Thanks much in advance for any direction you can give.  I've been searching for awhile without any luck.  Please let me know if you need additional info to diagnose the problem.

#2 oldmanice

oldmanice
  • Members
  • PipPipPip
  • Advanced Member
  • 134 posts
  • LocationIn Your Garden At Night

Posted 04 September 2006 - 12:41 AM

I had this problem its simple when you learn. Loalhost's cant be seen on other peoples computers its only on your owm pc. If you want people to access it thne you cant have localhost. but if you log onto http://whatismyip.com and get that number other people can access it buy typing in that number. I know it a stupid nuber and no one wants it but you will just have to live with it. Or if you really dont want it then you will have to buy a domain name. see like mine http://waterlakefield.com/wwe/ or http://86.17.240.228.

If you are in the usa I recommend you buy a domian name off http://register.com or in the uk http://easily.co.uk 

:'(


Join my Froums www.phpbbplanet.com/darkwinter

#3 levi_kim

levi_kim
  • New Members
  • Pip
  • Newbie
  • 4 posts

Posted 04 September 2006 - 02:00 AM

Thanks for replying oldmanice.

Unfortunately that's not my problem.  I am familiar with the difference between an IP address and a call to localhost.  The page I'm attempting to publish can be accessed on my machine, but not other machines when using the IP address.

Say my IP address were 12.345.67.89.

http://12.345.67.89:8888 connects fine from the hosting machine, but returns a 404 or connection timed out error from every other machine.

Oddly, entering 12.345.67.89:8888 on proxify.com will successfully access the page from any computer.

I'm not sure if the problem is with my ISP, with my Apache config files, or something else.  I'm also not sure how the call to the webpage via a proxy server differs from http.

Thanks again for trying.  Any more inputs would be appreciated.

#4 oldmanice

oldmanice
  • Members
  • PipPipPip
  • Advanced Member
  • 134 posts
  • LocationIn Your Garden At Night

Posted 04 September 2006 - 08:52 PM

Yes the reason http://proxify.com can access it is because it can access any website. The site you are working on is only avalible on your computer. To fix this either have your own domian name for it or just have it at your ip address if you find it out try it on another computer and it should work. If not then you have made a mistake somewhere and need to find and and fix it. Or maybe the :8888 bit needs to go. I personaly dont think you need 12.345.67.89:8888 just http://12.345.67.89
Join my Froums www.phpbbplanet.com/darkwinter

#5 levi_kim

levi_kim
  • New Members
  • Pip
  • Newbie
  • 4 posts

Posted 05 September 2006 - 04:03 AM

I'm apparently being unclear.  I know my IP address.  I'm using my IP address.  The problem is definitely not that I'm typing the wrong address into the address bar of my browser.  The problem is likely that I have a setting preventing outside machines from connecting via http.  Most frustrating is that my machine masks the problem by appearing to function properly until I make the trip to work to find my server still unaccessable.

it should work. If  not then you have made a mistake somewhere and need to find and and fix it.

This is exactly why I've come to the forum, hoping someone can help me find the mistake?

Or maybe the :8888 bit needs to go. I personaly dont think you need 12.345.67.89:8888 just http://12.345.67.89

Thanks, but using http://12.345.67.89 does not work, because it attempts to use the default port 80, which my ISP blocks.  That's why I specified the redirect.

#6 oldmanice

oldmanice
  • Members
  • PipPipPip
  • Advanced Member
  • 134 posts
  • LocationIn Your Garden At Night

Posted 05 September 2006 - 04:40 PM

That could be your problem the it cant work without port 80 on other computers. What you need to do is try and unblock port 80 then it should work.
Join my Froums www.phpbbplanet.com/darkwinter

#7 R_P

R_P
  • Members
  • PipPipPip
  • Advanced Member
  • 98 posts

Posted 05 September 2006 - 10:07 PM

levi_kim,

Connection difficulties could be a WIDE variety of issues. Here are some troubleshooting steps:

First, try to ping your maching from work, or outside your network by pulling up the cmd line and typing "ping 12.345.67.89" (or whatever your IP is). If you see packets being received, then it is likely that there's nothing blocking traffic to your machine. Likelihood is that if an external website can hit your machine, a ping should be successfull. Otherwise, you may have a firewall or physical connection issue.

Getting apache to work on non-standard ports shouldn't be that hard. Make sure that you have port 8888 in your httpd listen directive (apache should be listening to port 8888 for traffic). Also make sure to replace *80 with *8888 anywhere it exists in httpd.

Also, I'm not sure of your home network situation, but you may need a router in order to drive web traffic to your server machine, using the IP cox.net assigned you as the gateway address. These are settings that vary by provider (I don't use cox, sorry). Many providers filter ports 80,21,25 etc. specifically so you have to upgrade to their business packages to host webservers and running one on standard accounts is against most ISP's Usage policies. If they find out your running a personal web server, they could terminate your service (FYI).

Good Luck
Pro in: Win2K3S | Apache2 | PHP5 | Perl5 | MySQL | MSSQL | Firefox | Photoshop
Student of: Ubuntu6 | Java | C | VB.NET | ASP.NET
Developer: Roddzilla Webstudios, Burrson CG, DVIDSHUB, The Four Nations
Student: Georgia Tech, Georgia Tech College of Computing

#8 levi_kim

levi_kim
  • New Members
  • Pip
  • Newbie
  • 4 posts

Posted 07 September 2006 - 07:23 PM

Thanks R_P,

I can't get through with ping.  0 packets return every time.
Same result with my firewall turned off.  My modem & card are both pretty new.

I did replace 80 with 8888 in the httpd.conf.  I've also tried it listening on both ports.

Currently I'm only running the one machine at home, I don't have any others networked.

Cox does also block 25.  I'm comfortable that using the web server for what I want to do will not be in violation of my subscription's ToS, though thanks for the FYI.

Any other ideas?  In light of ping not working, I'm now truly baffled by the proxy server access.

#9 R_P

R_P
  • Members
  • PipPipPip
  • Advanced Member
  • 98 posts

Posted 07 September 2006 - 08:37 PM

The proxy server (if you were accessing it from your webserver) may only route traffic that it can access, otherwise may simply just try to show you the page if not. I'm sort of baffled on that one too.

I'm certainly not a network guru, but there are a few more steps you can take to identify where your having an issue.

First off, try assigning the webserver a static IP on your internal network. Then try accessing it from another computer (assuming you have another) on that network using the IP. If you are successful, that means there is no issue with the server hardware itself or software installed on the server. If you can't, check you network card and network config and ensure your physical connection from the router to server (which if you can access the internet shouldn't be a problem). If you're able to ping the internal address, but not access your website, then it is likely a firewall/apache configuration issue.

Check the manual that came with your home router to make sure port forwarding (port redirecting) is an option. What you will need to is forward the port that is handling internet traffic (8888) to  your server IP. Again, this is highly dependent on your router configuration. You will likely need to assign the IP that Cox gave you to the router itself. I understand that Cox may occasionally change these IP's so be wary of that. Make sure the gateway address in your servers network configuration is the internal IP of the router. And again, make sure you have a static IP in your router for your server.

Make sure that when you are trying to access your server at all times you use http://xxx.xxx.xxx.xxx:8888, no matter if you're on an internal or external network. Because connections are made on port 80 by default, just typing the IP address will send requests over port 80 and will miss 8888 altogether.

Sorry for the book. Its just that for beginners, setting up this kind of network requires a lot of patience and a fairly high learning curve and is different for just about everyone depending on their equipment and circumstances. It requires a slow, step by step, thorough setup.

Again, Good Luck.
Pro in: Win2K3S | Apache2 | PHP5 | Perl5 | MySQL | MSSQL | Firefox | Photoshop
Student of: Ubuntu6 | Java | C | VB.NET | ASP.NET
Developer: Roddzilla Webstudios, Burrson CG, DVIDSHUB, The Four Nations
Student: Georgia Tech, Georgia Tech College of Computing




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users