Jump to content


Photo

cann't upload a photo


  • Please log in to reply
3 replies to this topic

#1 lex m.

lex m.
  • New Members
  • Pip
  • Newbie
  • 1 posts

Posted 03 September 2006 - 10:34 AM

I have used a script by Wim vanden Eynde to upload and resize a photo, workes very good. I copied the page to a new domain and now it isn't working anymore. I tried another free php-upload script and it had the same problem, so it isn't the script, it has something to do on my side. the warnings i got were:
Warning: fopen(plaatjes/test.jpg): failed to open stream: Permission denied in /home/smsmarkt/domains/smsmarktplaats.nl/public_html/test.php on line 99

Warning: fwrite(): supplied argument is not a valid stream resource in /home/smsmarkt/domains/smsmarktplaats.nl/public_html/test.php on line 100
Er is een fout opgetreden bij het opladen van het bestand.
Warning: fclose(): supplied argument is not a valid stream resource in /home/smsmarkt/domains/smsmarktplaats.nl/public_html/test.php on line 109


what am I doing wrong, why is the permission denied?

#2 shocker-z

shocker-z
  • Members
  • PipPipPip
  • Advanced Member
  • 864 posts
  • LocationNottingham

Posted 03 September 2006 - 10:37 AM

sound slike permission to the folder your writing to is not set up properly.. it's not client side as it would block the upload from even getting to your server it sounds like a chmod issue

Liam
www: www.ukchat.ws | irc: irc.ukchat.ws chan: #blufudge

#3 AdRock

AdRock
  • Members
  • PipPipPip
  • Advanced Member
  • 911 posts

Posted 03 September 2006 - 08:19 PM

If it is the permissions you need to chmod the folder settings to allow write
If your topic has been solved, please mark the topic as SOLVED.

This helps others from identifying which topics need help still

#4 onlyican

onlyican
  • Members
  • PipPipPip
  • Advanced Member
  • 921 posts
  • LocationHants - UK

Posted 03 September 2006 - 11:57 PM

CHMOD should be either 755 or 777 (if 755 does not work)

IMPORTANT
Having a folder set to 777 leave it wide open, only allow user uploads in that folder
Tell me the problem, I will try tell you the solution




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users