Jump to content


Photo

shell_exec() prog prob


  • Please log in to reply
7 replies to this topic

#1 nadeemshafi9

nadeemshafi9
  • Members
  • PipPipPip
  • Advanced Member
  • 1,245 posts
  • LocationUK

Posted 04 September 2006 - 12:29 AM

hi all

i hav aprob running a programm i downloaded.

<?php 
	$cmd = "soxmix tmp/audio1.wma tmp/audio2.wma tmp/final.wma";
	shell_exec($cmd);
?>

pretend u wanted to execute the above code, you just downloaded the soxmix software its an exe, where would you place the software. i would have thoght system32 or somthing, can somone please give me a hand.

thanx
DONT LAY AN EGG OVER IT

#2 Jenk

Jenk
  • Members
  • PipPipPip
  • Advanced Member
  • 778 posts

Posted 04 September 2006 - 01:34 AM

<?php 
	$cmd = "soxmix tmp/audio1.wma tmp/audio2.wma tmp/final.wma";
	echo shell_exec($cmd);
?>
output?

#3 nadeemshafi9

nadeemshafi9
  • Members
  • PipPipPip
  • Advanced Member
  • 1,245 posts
  • LocationUK

Posted 04 September 2006 - 01:38 AM

well it says nothin im running windows
DONT LAY AN EGG OVER IT

#4 nadeemshafi9

nadeemshafi9
  • Members
  • PipPipPip
  • Advanced Member
  • 1,245 posts
  • LocationUK

Posted 04 September 2006 - 01:39 AM

i dont know were to place the soxmix file its a program that concatinates two audio files
DONT LAY AN EGG OVER IT

#5 Jenk

Jenk
  • Members
  • PipPipPip
  • Advanced Member
  • 778 posts

Posted 04 September 2006 - 01:40 AM

do you get any output when you run it manually? (in command prompt)

#6 nadeemshafi9

nadeemshafi9
  • Members
  • PipPipPip
  • Advanced Member
  • 1,245 posts
  • LocationUK

Posted 04 September 2006 - 01:42 AM

yes it worke fine from the command line
DONT LAY AN EGG OVER IT

#7 Jenk

Jenk
  • Members
  • PipPipPip
  • Advanced Member
  • 778 posts

Posted 04 September 2006 - 01:49 AM

but do you get any output?

#8 nadeemshafi9

nadeemshafi9
  • Members
  • PipPipPip
  • Advanced Member
  • 1,245 posts
  • LocationUK

Posted 04 September 2006 - 03:48 AM

i hav solved it i put the full path in to the function and i placed the directory in the php.ini file safe_mod_dir

thanx alot though for your help
DONT LAY AN EGG OVER IT




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users