Jump to content


Photo

Redirect port 80 to port 8222


  • Please log in to reply
8 replies to this topic

#1 xadamz23

xadamz23
  • New Members
  • Pip
  • Newbie
  • 4 posts

Posted 06 September 2006 - 03:02 PM

Hello,

I am running VMware Server and have installed the Management Interface.  By default the interface is accessed on port 8222.  However, I dont want my users to have to specify a port in their web browser.

I need the following redirection to happen:

http://vm1 ----> http://vm1:8222

I have scoured the internet and tried changing the httpd.conf file, but the redirection never works.

What can I do to get the redirection?

#2 oldmanice

oldmanice
  • Members
  • PipPipPip
  • Advanced Member
  • 134 posts
  • LocationIn Your Garden At Night

Posted 06 September 2006 - 03:20 PM

I think you might need to use Mod Rewright
Join my Froums www.phpbbplanet.com/darkwinter

#3 xadamz23

xadamz23
  • New Members
  • Pip
  • Newbie
  • 4 posts

Posted 06 September 2006 - 03:50 PM

I have tried that, but I am not sure if I am using the correct syntax.

In my httpd.conf file:

RewriteEngine on
RewriteRule (I cant remember the rule I used)

Do you know what I would need given the URLs in my first post?

#4 oldmanice

oldmanice
  • Members
  • PipPipPip
  • Advanced Member
  • 134 posts
  • LocationIn Your Garden At Night

Posted 06 September 2006 - 09:18 PM

Have you tried making a vhost?
Join my Froums www.phpbbplanet.com/darkwinter

#5 xadamz23

xadamz23
  • New Members
  • Pip
  • Newbie
  • 4 posts

Posted 06 September 2006 - 09:26 PM

I havent tried using a vhost.  I am not familier with that.  Unless that is the same thing as VirtualHost?

#6 oldmanice

oldmanice
  • Members
  • PipPipPip
  • Advanced Member
  • 134 posts
  • LocationIn Your Garden At Night

Posted 06 September 2006 - 09:42 PM

Yes it is
Join my Froums www.phpbbplanet.com/darkwinter

#7 R_P

R_P
  • Members
  • PipPipPip
  • Advanced Member
  • 98 posts

Posted 06 September 2006 - 10:00 PM


RewriteEngine on
RewriteRule ^/vm1(.*) http://myserver:8222$1


Should look something like that if you have mod_rewrite enabled. Another (quick and dirty) solution would be to create an index page in */vm1 with an actual javascript or meta redirect.

Good luck.
Pro in: Win2K3S | Apache2 | PHP5 | Perl5 | MySQL | MSSQL | Firefox | Photoshop
Student of: Ubuntu6 | Java | C | VB.NET | ASP.NET
Developer: Roddzilla Webstudios, Burrson CG, DVIDSHUB, The Four Nations
Student: Georgia Tech, Georgia Tech College of Computing

#8 xadamz23

xadamz23
  • New Members
  • Pip
  • Newbie
  • 4 posts

Posted 06 September 2006 - 10:13 PM


RewriteEngine on
RewriteRule ^/vm1(.*) http://myserver:8222$1


Should look something like that if you have mod_rewrite enabled. Another (quick and dirty) solution would be to create an index page in */vm1 with an actual javascript or meta redirect.

Good luck.



Didnt work, I might not have mod_rewrite enabled.  Just to clarify:

Hostname = vm1
I want URL "http://vm1" redirected to URL "http://vm1:8222

#9 R_P

R_P
  • Members
  • PipPipPip
  • Advanced Member
  • 98 posts

Posted 06 September 2006 - 10:36 PM

to enable mod_rewrite, you need to uncomment:

#LoadModule rewrite_module modules/mod_rewrite.so

in apache httpd.config and then restart apache if you are on your own machine. to see if it is already running, you can take a gander at phpinfo() and look for loaded apache modules.
Pro in: Win2K3S | Apache2 | PHP5 | Perl5 | MySQL | MSSQL | Firefox | Photoshop
Student of: Ubuntu6 | Java | C | VB.NET | ASP.NET
Developer: Roddzilla Webstudios, Burrson CG, DVIDSHUB, The Four Nations
Student: Georgia Tech, Georgia Tech College of Computing




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users