Jump to content

Archived

This topic is now archived and is closed to further replies.

vesper8

been trying for over an hour.. i give up =\ apache and router =\

Recommended Posts

Hey all.. believe me.. I've tried everything I can think of before I came and posted this question. I can see that this is a very popular topic.. but reading other's questions did lead me to try new things but none of them worked.

It's probably something really stupid I'm missing but.. hopefully you can put an end to this headache.

All i'm trying to do is set up a apache server so I can host a small website for school from my computer.

I installed the latest version of WAMP5.

i put my site files in wamp/www/

and I tested it with localhost and that works fine

I notice when I start wamp it says 'all services running - server offline'

i'm starting to think it shouldn't be saying server offline there.. because that might mean it's ONLY gonna allow the site to be viewed from localhost no matter what I put in there...

anyway.. I have a buffalo airstation wireless router. Though this computer is connected to it via a RJ-45 cable. At first I was using DHCP but after reading in this forum I changed both computers to use static IPs and I disabled the router's DHCP.. Everything works fine as before (internet and all).

I then tried to forward port 80 to this machine's IP.. I tried forwarding other ports as well and changing the port that apache listens to in httpd.conf

I tried specifying the IP apache listens to instead of just the port and I set it to this computer's IP (the one with apache on it).

well nothing works. Whenever I try to access the site via my router's dynamic address.. I just get prompted for my router's login/password and it logs me onto it.. It doesn't seem to want to get past it

but oddly.. all my other port forwardings work just fine.. I know they do otherwise some of my apps wouldn't be working properly.

Please help.. is it the fact apache says 'server offline' that's screwing me? how do I change that ? if that's not it.. then any idea what it might be? I know how to port forward normally... this is just weird.. I don't understand why it won't work

thanks guys.. i appreciate it

Share this post


Link to post
Share on other sites
well heh... i am so blind.. i just found the darn 'put online' button... *sad*

anyway that takes care of the 'server offline' problem

but alas it still doesn't work.. I'm listing on port 80 in the httpd.conf

and i've forwarded both tcp/udp port 80 to my local ip.. and still nothing

what's wrong ? =\

Share this post


Link to post
Share on other sites
Does your machine have a static IP that the router is forwarding 80 to?

Share this post


Link to post
Share on other sites
So...

1. The cable enters your home.
2. The cable goes into your modem.
3. Your modem's network cable plugs into the WAN port of your router.
4. All of your other machine's are either (a) plugged into your router; or (b) configured to work with it wirelessly.
5. The machine acting as a server is outside of the DHCP pool and assigned a static IP.
6. The router has been configured to forward requests on port 80 to this IP. (And the router was rebooted after making this change, as most require it.)
7. Apache is running and set up to listen on the IP, port 80.
8. There are no firewalls preventing communication.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.