Jump to content


Photo

Gaining access to a folder


  • Please log in to reply
4 replies to this topic

#1 symband

symband
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 07 January 2003 - 04:11 AM

I have a website currently running in X:Apachehtdocs, and I\'m trying to have a link to my mp3 folder for my friends to be able to browse. The folder is X:Music, and I\'ve tried a couple things but haven\'t gotten it to grant access to that folder, always getting \"Forbidden\". This is what I\'ve put in my apache conf file:


<Directory "X:/Music">

    AllowOverride None

    Options None

    Order allow,deny

    Allow from all

</Directory>


and also


ScriptAlias /music/ "X:/Music"


I\'ve tried changing it from <Directory \"X:/Music\"> to \"/music\", and also a couple other things, but I have a feeling thats not the problem. Any help?[/code]

#2 dakkon10

dakkon10
  • New Members
  • Pip
  • Newbie
  • 1 posts
  • LocationNew Jersey

Posted 07 January 2003 - 06:48 AM

i know this has really nothing with what you want to do, but you could just put your music folder into your htdocs folder, and put a password on it. i\'m a noob also, otherwise i\'d give you some really super good never fail ya code. :?
New to apache, new to php, kinda new to html, i\'m an all around newbie =)

#3 effigy

effigy
  • Staff Alumni
  • Advanced Member
  • 3,600 posts
  • LocationIL

Posted 07 January 2003 - 09:11 AM

this can easily be done in unix with symbolic links, does windows have a feature common to that? otherwise, i don\'t think you\'ll be able to stray out of the document root.
Regexp | Unicode Article | Letter Database
/\A(e)?((1)?ff(?:(?:ig)?y)?|f(?:ig)?)\z/

#4 pallevillesen

pallevillesen
  • Members
  • PipPipPip
  • Advanced Member
  • 135 posts
  • LocationDenmark

Posted 07 January 2003 - 10:46 AM

Use an alias!

My document root is a completely different place!

I hope this is enough,
P., denmark

#
# Aliases: Add here as many aliases as you need (with no limit). The format is  
# Alias fakename realname
#
<IfModule mod_alias.c>

   #
   # Note that if you include a trailing / on fakename then the server will
   # require it to be present in the URL.  So \\\"/icons\\\" isn\'t aliased in this
   # example, only \\\"/icons/\\\".  If the fakename is slash-terminated, then the  
   # realname must also be slash terminated, and if the fakename omits the  
   # trailing slash, the realname must also omit it.
   #
   Alias /icons/ \\\"/home/arginine/genchip/apacheServer/icons/\\\"

   <Directory \\\"/home/arginine/genchip/apacheServer/icons\\\">
       Options Indexes MultiViews
       AllowOverride None
       Order allow,deny
       Allow from all
   </Directory>

   # This Alias will project the on-line documentation tree under /manual/
   # even if you change the DocumentRoot. Comment it if you don\'t want to  
   # provide access to the on-line documentation.
   #
   Alias /manual/ \\\"/home/arginine/genchip/apacheServer/htdocs/manual/\\\"

   <Directory \\\"/home/arginine/genchip/apacheServer/htdocs/manual\\\">
       Options Indexes FollowSymlinks MultiViews
       AllowOverride None
       Order allow,deny
       Allow from all
   </Directory>


I have a website currently running in X:Apachehtdocs, and I\'m trying to have a link to my mp3 folder for my friends to be able to browse.  The folder is X:Music, and I\'ve tried a couple things but haven\'t gotten it to grant access to that folder, always getting \\\"Forbidden\\\".  This is what I\'ve put in my apache conf file:


<Directory "X:/Music">

    AllowOverride None

    Options None

    Order allow,deny

    Allow from all

</Directory>


and also


ScriptAlias /music/ "X:/Music"


I\'ve tried changing it from <Directory \\\"X:/Music\\\"> to \\\"/music\\\", and also a couple other things, but I have a feeling thats not the problem.  Any help?[/code]


Palle Villesen, www.birc.dk [br]Bioinformatics Research Center

#5 symband

symband
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 07 January 2003 - 11:13 PM

Still doesn\'t work, I put Alias /music/ \"X:/Music/\" and then the Directory directive, and I still get 403 Forbidden when trying to access the folder through mysite.com/music/. I\'ve even checked the folder permissions, and its set so that everyone has access...so I really dunno what else to do. I know there has to be a way to do it without moving the folder (too inconvenient, its a big folder).




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users