Jump to content

Archived

This topic is now archived and is closed to further replies.

apache_cake

Apache Module Load Error

Recommended Posts

Hi Guys,
              I recently installed Fedora 5 (.2174) and wanted to setup webserver with it. I did some settings using the GUI of httpd i.e, system-config-httpd. When I tried to start httpd from the terminal I got this error.

[root@localhost ~]# httpd
httpd: Syntax error on line 194 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/mod_access.so into server: /etc/httpd/modules/mod_access.so: undefined symbol: array_free


So I deleted the line 194 from the httpd.conf file and restarted httpd

[root@localhost ~]# httpd
httpd: Syntax error on line 195 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/mod_auth.so into server: /etc/httpd/modules/mod_auth.so: undefined symbol: int2hex

Again I deleted the 195th line so see this

[root@localhost ~]# httpd
httpd: Syntax error on line 196 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/mod_auth_anon.so into server: /etc/httpd/modules/mod_auth_anon.so: cannot open shared object file: No such file or directory


I went on deleting the line with error till I was sick of doing this ..... and finally found this forum.....
Please help me.....

Share this post


Link to post
Share on other sites
Have you confirmed the module files actually exist where the path in your conf file says they are? I've never used apache on Fedora, so there are some questions to be answered like if relative naming works. I'm guessing the lines you are deleting look something like this:

LoadModule access_module modules/mod_access.so

First off some of these are standard, required modules. Second, its not advisable to delete lines from your apache config file, rather comment them out using the #. Third, addressing your problem make sure that inside your apache directory a modules folder exists. Make sure that all the .so files are in there. If they are and your still having problems, try changing the path (the third parameter) to an absolute path (from your root).

Also make sure you have the right build for apache. I know in some instances you have to also use the AddModule directive in addition to LoadModule in httpd.config.

Hope this helps, good luck.

Share this post


Link to post
Share on other sites
Problem registered in Bugzilla:https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=180056

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.