Jump to content


Photo

unable to test the "phpinfo.php"


  • Please log in to reply
4 replies to this topic

#1 nuq

nuq
  • New Members
  • Pip
  • Newbie
  • 3 posts

Posted 25 October 2004 - 07:40 AM

Hi,

I followed the "Setting Up PHP, MySQL, and Apache Server Platform on Mac..." from Macromedia Development center. When i run the test by browsing for phpinfo.php file, the browser automatically download the file instead of open it to get the php info. Can anybody help me with this?

Appriciate the help.
harun


#2 gizmola

gizmola
  • Administrators
  • Advanced Member
  • 4,664 posts
  • LocationLos Angeles, CA USA

Posted 25 October 2004 - 10:02 AM

Your apache httpd.conf is not configured correctly to recognize .php files as requiring php parsing. There's a number of possible reasons for this. Make sure first off that you have an addtype statement for .php files, or reread the installation instructions for php and make sure you have not missed something. Detailed php installation instructions can be found at php.net.

#3 nuq

nuq
  • New Members
  • Pip
  • Newbie
  • 3 posts

Posted 26 October 2004 - 04:37 AM

I retried the steps, there is one thing i am not sure. When the instruction says "Uncommented ..." how do i do that. What i did was just delete the "#" mark in front of the line.


Applogize for being an ignorance
nuq

#4 sonjay

sonjay
  • New Members
  • Pip
  • Newbie
  • 4 posts
  • LocationThe Hurricane State

Posted 26 October 2004 - 12:20 PM

"Uncomment" does mean to delete the # mark at the front of the line. (All of them, if there's more than one.) So it sounds like you've done that correctly, assuming you've uncommented the correct lines in there.

You also need to restart Apache after making a change to your httpd.conf file. GUI method (if you're using Apple's default Apache install): System Preferences -> Sharing -> Personal Web Sharing -> Stop and then start "Personal Web Sharing."

CLI method (using any Apache install): in Terminal, type "sudo apachectl graceful" or "sudo apachectl restart"



#5 nuq

nuq
  • New Members
  • Pip
  • Newbie
  • 3 posts

Posted 27 October 2004 - 05:12 AM

heeee haw,

its working now. :lol:
The problem was the restarting the apache.

Thanx a million, till the next problem.
harun




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users