Jump to content

Archived

This topic is now archived and is closed to further replies.

karstev

Enable MySQL Support in PHP5!

Recommended Posts

Please does anyone have any ideas, I am banging my head against a wall, seems I have done all that is mentioned and still cant get php to communicate with mySQL - mys system info is
PHP - 5.1.4
mySQL - 5.0
Appache 2.2.3
Windows XPSP2

I have updated my php.ini, set up the extension_dir = c:\php\ext  (yes this path exists), uncommented extension=php_myql.dll.
placed the php.ini in my windows directory (just incase)as I updated my environment variable path to include c:\php, and this is confirmed when viewing my phpinfo. Copied the libmysql.dll to my windows directory, also put it in the system32 directory just to be sure. Made sure I stopped and restarted the server, heck I even shut down windows and restarted just to be sure..
Should I use another version of appache.
I know this has been posted many times but have been through all of recommended changes and cant seem to fix this issue.

Hope some one can help



Share this post


Link to post
Share on other sites
Are you using Wamp? If you are using it you don't need to change anything else..
Just run both the services and your done..

Share this post


Link to post
Share on other sites
I'm pretty sure I have the same problem.

I'm using pretty much the same setup as you (Apache 2.2.3, PHP 5.2, MySQL 5.0.24a on WinXP SP1) and I'm unable to get PHP and MySQL to work together.

Have you found a solution to this problem?

Share this post


Link to post
Share on other sites
uncomment the mysql extension in your php.ini file
extension=php_mysql.dll

then copy libmysql.dll from you php directory your system32 folder restart apache server...

Share this post


Link to post
Share on other sites
myself I don't put in it the Windows Dirs

when installing php I copy all the DLLs from the PHP folder to the Apache's bin folder as well as the php.ini file

and like vbnullchar said...you need
to put
extension_dir = c:/php/ext
in your Apache's http.conf file
try it that way and restart Apache and see how it goes....

Share this post


Link to post
Share on other sites
I'm having the same sort of issue. I'm creating my own WAMP because others aren't quite what I'm looking for. I've got everything working, except that I can't get the php extension to work. I've modified php.ini with extension_dir to ="./ext/" and have commented out both php_mysql.dll and php_mysqli.dll extensions, and also copied them to the root php dir. Everything suggested in this thread has been tried (well, almost).

Using: php 5.2.0 and mysql 5.1.14-beta

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.