Jump to content


Photo

Http Forms - unable to submit and run php


  • Please log in to reply
4 replies to this topic

#1 Devin_Sheridan

Devin_Sheridan
  • New Members
  • Pip
  • Newbie
  • 3 posts

Posted 12 September 2006 - 03:04 AM

I am trying call a .php file from an HTTP form but all I get is the .php file's code brought up in a notepad window. Any ideas on what in my configuration is going wrong?  I am able to run .php files thru my browser, just not from forms.  Here is what I have for code:

<html>
<HEAD>
<TITLE>URL DATA ENTRY</TITLE>
</HEAD>

<BODY> <h4>URL DATA ENTRY FORM</h4>
<form action="addUrlForm.php" method="post">

<p> URL = <input type="text" size="75" name="url" > </p>

<p> Description = <textarea rows="5" wrap="VIRTUAL" name="description"></textarea> </p>

<p> Service = <input type="text" size="72" name="service" /> </p>

<INPUT TYPE="submit" VALUE="Send!">

</FORM>

</body></html>

addUrlForm.php

<?php

require_once('C:\Program Files\xampp\htdocs\linkmanager.php');

$url = $_POST['url'];
$description = $_POST['description'];
$service = $_POST['service'];

$lm = new linkmanager();
$lm->addLink_uds($url, $description, $service);

echo 'Url = '.$url;

?>

#2 karthikeyan_coder

karthikeyan_coder
  • Members
  • PipPipPip
  • Advanced Member
  • 201 posts

Posted 14 September 2006 - 08:04 PM

Some one from PHPFreaks... Please move this topic to php help forums.
www.karthi.us

#3 wildteen88

wildteen88
  • Staff Alumni
  • Advanced Member
  • 10,482 posts
  • LocationUK, Bournemouth

Posted 15 September 2006 - 10:07 AM

This seems to a coniguration problem with your server. What server have you got installed (APache, IIS) alsow what version of PHP do you have installed and how is PHP configured with your server?

#4 Devin_Sheridan

Devin_Sheridan
  • New Members
  • Pip
  • Newbie
  • 3 posts

Posted 16 September 2006 - 11:56 AM

I used the XAMPP package to install the web server on my computer. It uses PHP version 5.1.6 and apache version 2.2.3.

#5 Devin_Sheridan

Devin_Sheridan
  • New Members
  • Pip
  • Newbie
  • 3 posts

Posted 16 September 2006 - 12:03 PM

here is my phpinfo() which does work properly:

Configuration
PHP Core
Directive Local Value Master Value
allow_call_time_pass_reference On On
allow_url_fopen On On
always_populate_raw_post_data Off Off
arg_separator.input & &
arg_separator.output &amp; &amp;
asp_tags Off Off
auto_append_file no value no value
auto_globals_jit On On
auto_prepend_file no value no value
browscap C:\Program Files\xampp\php\browscap\browscap.ini C:\Program Files\xampp\php\browscap\browscap.ini
default_charset no value no value
default_mimetype text/html text/html
define_syslog_variables Off Off
disable_classes no value no value
disable_functions no value no value
display_errors On On
display_startup_errors Off Off
doc_root no value no value
docref_ext no value no value
docref_root no value no value
enable_dl On On
error_append_string no value no value
error_log no value no value
error_prepend_string no value no value
error_reporting 2039 2039
expose_php On On
extension_dir C:\Program Files\xampp\php\ext\ C:\Program Files\xampp\php\ext\
file_uploads On On
highlight.bg #FFFFFF #FFFFFF
highlight.comment #FF8000 #FF8000
highlight.default #0000BB #0000BB
highlight.html #000000 #000000
highlight.keyword #007700 #007700
highlight.string #DD0000 #DD0000
html_errors On On
ignore_repeated_errors Off Off
ignore_repeated_source Off Off
ignore_user_abort Off Off
implicit_flush Off Off
include_path .;C:\Program Files\xampp\php\pear\ .;C:\Program Files\xampp\php\pear\
log_errors Off Off
log_errors_max_len 1024 1024
magic_quotes_gpc On On
magic_quotes_runtime Off Off
magic_quotes_sybase Off Off
mail.force_extra_parameters no value no value
max_execution_time 60 60
max_input_time 60 60
open_basedir no value no value
output_buffering no value no value
output_handler no value no value
post_max_size 16M 16M
precision 12 12
realpath_cache_size 16K 16K
realpath_cache_ttl 120 120
register_argc_argv On On
register_globals Off Off
register_long_arrays On On
report_memleaks On On
report_zend_debug On On
safe_mode Off Off
safe_mode_exec_dir no value no value
safe_mode_gid Off Off
safe_mode_include_dir no value no value
sendmail_from no value no value
sendmail_path no value no value
serialize_precision 100 100
short_open_tag On On
SMTP localhost localhost
smtp_port 25 25
sql.safe_mode Off Off
track_errors Off Off
unserialize_callback_func no value no value
upload_max_filesize 16M 16M
upload_tmp_dir C:\Program Files\xampp\tmp C:\Program Files\xampp\tmp
user_dir no value no value
variables_order EGPCS EGPCS
xmlrpc_error_number 0 0
xmlrpc_errors Off Off
y2k_compliance On On
zend.ze1_compatibility_mode Off Off


apache2handler
Apache Version  Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8c mod_autoindex_color PHP/5.1.6 
Apache API Version  20051115 
Server Administrator  admin@localhost 
Hostname:Port  localhost:80 
Max Requests  Per Child: 0 - Keep Alive: on - Max Per Connection: 100 
Timeouts  Connection: 300 - Keep-Alive: 5 
Virtual Server  No 
Server Root  C:/Program Files/xampp/apache 
Loaded Modules  core mod_win32 mpm_winnt http_core mod_so mod_actions mod_alias mod_asis mod_auth_basic mod_authn_default mod_authn_file mod_authz_default mod_authz_groupfile mod_authz_host mod_authz_user mod_cgi mod_dav mod_dav_fs mod_dir mod_env mod_include mod_info mod_isapi util_ldap mod_log_config mod_mime mod_negotiation mod_setenvif mod_status mod_ssl mod_autoindex_color mod_php5 

Directive Local Value Master Value
engine 1 1
last_modified 0 0
xbithack 0 0


Apache Environment
Variable Value
AuthDigestEnableQueryStringHack  On 
HTTP_ACCEPT  image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, */* 
HTTP________  ----:-------------------------- 
HTTP_ACCEPT_LANGUAGE  en-us 
HTTP_ACCEPT_ENCODING  gzip, deflate 
HTTP_USER_AGENT  Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.0.3705; .NET CLR 1.1.4322; .NET CLR 2.0.50727; Media Center PC 4.0) 
HTTP_HOST  localhost 
HTTP_CONNECTION  Keep-Alive 
PATH  c:\ruby\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;c:\Python22;C:\Program Files\PC-Doctor for Windows\services;C:\Program Files\ATI Technologies\ATI Control Panel;C:\Program Files\QuickTime\QTSystem\ 
SystemRoot  C:\WINDOWS 
COMSPEC  C:\WINDOWS\system32\cmd.exe 
PATHEXT  .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.RB;.RBW 
WINDIR  C:\WINDOWS 
SERVER_SIGNATURE  <address>Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8c mod_autoindex_color PHP/5.1.6 Server at localhost Port 80</address> 
SERVER_SOFTWARE  Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8c mod_autoindex_color PHP/5.1.6 
SERVER_NAME  localhost 
SERVER_ADDR  127.0.0.1 
SERVER_PORT  80 
REMOTE_ADDR  127.0.0.1 
DOCUMENT_ROOT  C:/Program Files/xampp/htdocs 
SERVER_ADMIN  admin@localhost 
SCRIPT_FILENAME  C:/Program Files/xampp/htdocs/xampp/phpinfo.php 
REMOTE_PORT  3434 
GATEWAY_INTERFACE  CGI/1.1 
SERVER_PROTOCOL  HTTP/1.1 
REQUEST_METHOD  GET 
QUERY_STRING  no value 
REQUEST_URI  /xampp/phpinfo.php 
SCRIPT_NAME  /xampp/phpinfo.php 


HTTP Headers Information
HTTP Request Headers
HTTP Request  GET /xampp/phpinfo.php HTTP/1.1 
Accept  image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, */* 
-------  ----:-------------------------- 
Accept-Language  en-us 
Accept-Encoding  gzip, deflate 
User-Agent  Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.0.3705; .NET CLR 1.1.4322; .NET CLR 2.0.50727; Media Center PC 4.0) 
Host  localhost 
Connection  Keep-Alive 
HTTP Response Headers
X-Powered-By  PHP/5.1.6 
Keep-Alive  timeout=5, max=98 
Connection  Keep-Alive 
Transfer-Encoding  chunked 
Content-Type  text/html 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users