Jump to content

Archived

This topic is now archived and is closed to further replies.

damiro

PHP 5.1.6 installation with IIS

Recommended Posts

im new in PHP and i cant install the "php-5.1.6-Win32" from the download zone of PHP.net. is there anyone here knows how will i install this properly? My server is using Windows NT 2000 with IIS. i created an phpinfo() file to test if the installation of php is working.

the error prompted as:

HTTP 403.1 Forbidden: Execute Access Forbidden
Internet Information Services

You have attempted to execute a CGI, ISAPI, or other executable program from a directory that does not allow programs to be executed.

anyone here know what seem to be the problem? i followed the instructions in http://www.hostlibrary.com/Building-a-PHP-...b-hosting-.html

its my third week already installing this thing  ???... thanks for your reply.. 

Share this post


Link to post
Share on other sites
I couldn't get it work under IIS either... but I did at least get pass that problem.

What you need to do is go into IIS and change the Permission on the Home Directory tab.

Do a right over your site... go down to properties and then to the Home Dir tab.....

Hope this helps.

Share this post


Link to post
Share on other sites
I have php 5.1.2 on IIS installed (as ISAPI not with the installer) and it works fine.  I didn't have any problems with the install, I followed the Manual Installation steps from the php docs, but I did have to give some execute permissions to the IIS user account in c:\php, and for whatever reason the active php.ini file is in c:\windows rather than c:\php

Share this post


Link to post
Share on other sites
These two sites are what got me through installing on IIS.

http://www.photosector.com/Sections+index-req-viewarticle-artid-27-page-1.html

http://www.peterguy.com/php/install_IIS6.html

They are amazing as they work  ;D

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.