Jump to content


Photo

PHP pages fail to preview in Dreamweaver MX


  • Please log in to reply
2 replies to this topic

#1 kelly001

kelly001
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 11 November 2004 - 06:18 PM

Hi,

I am trying to develop a dynamic site hosted locally on my Mac running OS 10.3.3 I have enabled PHP Version 4.3.2 and Apache 1.3.29. and both seem to be running from what i can tell. Apache shows a default page at http://127.0.0.1 and PHP shows the same at http://127.0.0.1/~user/phpinfo.php
I'm using Dreamweaver MX 6.1 with MySQL. I am able to connect to the database without any problem.

However, when I try to preview one of the site's pages in IE or Safari I get "the request URL /TMPacifg6yv5.php was not found on this server"

What could be causing this??? Is PHP not enabled properly?

#2 kelly001

kelly001
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 11 November 2004 - 07:32 PM

One thing I noticed too is that when I try to do a "Live Data" view of a PHP page I also run into an error. It tells me "HTTP error 404 (file not found) occured while attempting to request the file http://127.0.0.1/php...dgmpy70r5f.php" from testing server."
What is going on with this? Is this related?

#3 phpdood

phpdood
  • Members
  • Pip
  • Newbie
  • 1 posts
  • LocationBuffalo, New York

Posted 22 November 2004 - 01:51 AM

Don't you just LOVE dreamweaver sometimes? This problem is fun, and easy to fix...most of the time.

First off, if you are on Mac OS X ( I assume you are), make sure you have installed the PHP add-on from php.net.

Next, this is going to sound dumb, but, TURN APACHE ON...Go to apple, system prefs, sharing, turn ON personal file sharing....Just for kicks, go to http://127.0.0.1/~username. If you don't have anything showing up or an error, something is wrong. Make sure apache is turned on. You can see by taking out the username portion of 127.0.0.1, and if it shows a setup-completion page you are in the go.


Now, as far as previewing in Dreamweaver, that works sometimes, and not. The easiest way I do it is by going to http://127.0.0.1/~us...ename/index.php

Let me know if this works. It takes a little extra effort alt-tabbing, but at least you don't have to waste the extra 2 seconds uploading :huh:
FissionHost Web Hosting[br]Fast servers, low cost, and GREAT customer service. PHP Safe mode turned off!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users