Jump to content

Archived

This topic is now archived and is closed to further replies.

pakenney38

Apache upload file size limit

Recommended Posts

I have a web form that is used to upload some 33 files at once to an "/uploads" folder on my web server, but am having an issue with Apache not wanting to deal with file sizes larger than 6-7MB per file. If I attempt to upload any file larger than that, I get "the page cannot be displayed" in the browser. At first, I blamed PHP. But then I rewrote the processing script in Perl, and now have the same issue with the Perl script. So I have to blame Apache.

Share this post


Link to post
Share on other sites
No it isnt the apache server what this means is your computer cant hold much space because the files are to big. I think your going to have to get more MB

Share this post


Link to post
Share on other sites
You mean like the Web Server? It has 250 GB of hard drive space, 82% of that is available. It also has 2 GB of RAM. I'm confused on how this cannot be adequate.
Or were you referring to the PC I am sending the files from? I still don't understand how a file that is at most 16MB would eat enough resources on either the client or server to cause this problem. Could you be more specific?

Share this post


Link to post
Share on other sites
Well if it has 250 GB of hard drive space, 82% of that is available then it should be fine maybe the version you are using dose not accept files higher than 6-7 MB you might want to download a higher version.

And if that also dosent work then try more MB

Share this post


Link to post
Share on other sites
It would be nice to have a serious reply to this topic. First of all, I recently updated all packages through yum, so I know everything is current version. Secondly, are you suggesting I update the RAM? Even the RAM is 2GB. If that's not enough to process say, and 16MB file, then there is some other problem.

Share this post


Link to post
Share on other sites
Few questions:

When you were working with PHP, did you modify PHP.ini so that PHP and the POST method can handle those file sizes? I haven't tried modding a Perl config, so I don't know if there are similar settings to look at, but in PHP.ini take a look at these settings (and change per your req's):

; Maximum size of POST data that PHP will accept.
post_max_size = 8M

; Maximum allowed size for uploaded files.
upload_max_filesize = 2M

You also might want to try looking at the resource limits to make sure that PHP isn't hitting them, although you would be returned PHP errors, not page/access errors if that were the case.

Additionally... Is the server on your local machine? Do you get the same error when you upload via a localhost address? If not, then it may be a network timeout issue.

If you get the same error from localhost or you don't think its a network issue, the time it takes to process a large file maybe exceeding apache's Timeout setting which I believe defaults to 5 mins.

Good luck.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.