Jump to content


Photo

PostGreSQl - Fatal error: Call to undefined function: pg_connect()


  • Please log in to reply
4 replies to this topic

#1 hc

hc
  • Members
  • PipPip
  • Member
  • 14 posts

Posted 15 September 2006 - 04:35 PM

I realize this error is from the fact that PHP does not recognize that I have PostGreSQL installed, but how do I fix it? I am running Windows 2003, IIS 6, and PHP 4.4(?) I used the windows installer version. Thanks for any help.

hc

#2 bholbrook

bholbrook
  • Members
  • PipPipPip
  • Advanced Member
  • 31 posts

Posted 15 September 2006 - 06:17 PM

Don't run PG, PHP, or anything useful on Windows, that should fix all your problems...


If you're deadset on windows, you need to put the .dll provided with Postgres into the extensions folder that php uses (often ext/ in your php folder) and then turn it on in the php.ini file

That should do 'er.

#3 hc

hc
  • Members
  • PipPip
  • Member
  • 14 posts

Posted 15 September 2006 - 08:51 PM

Thanks. I sort of HAVE to do this on Windows. It is my only available box right now. I dont have time to redo another one for PHP, PG.

Would you any chance know the name of the DLL for PG? And How do I turn it on in the PHP.ini?

I basically copied all the .dll in the PostGresql bin folder, but it did nothing. I thought it already WAS enabled in the PHP.INI, but no dice. Any thoughts? Thanks alot

#4 hc

hc
  • Members
  • PipPip
  • Member
  • 14 posts

Posted 16 September 2006 - 01:49 PM

anyone? Any help would be appreciated. Thanks

HC

#5 hc

hc
  • Members
  • PipPip
  • Member
  • 14 posts

Posted 21 September 2006 - 05:14 PM

anyone with any thoughts on getting this running. I still cant get it figured out. Thanks

HC




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users