Jump to content


Photo

Unable to upload files larger than 2MB


  • Please log in to reply
6 replies to this topic

#1 ci5ic

ci5ic
  • New Members
  • Pip
  • Newbie
  • 5 posts

Posted 18 September 2006 - 04:59 AM

So, I am writing an upload script (for MP3's) that will not allow me to upload a file larger than 2MB.

I am unable to modify any settings in the php.ini because it is controlled by the hosting server that my page is on.

I've tried adding various forms of the following to my script without any luck:

ini_set("upload_max_filesize","8MB")
ini_set("upload_max_filesize","800000"), etc.

I've also tried using php's ftp_put function as well, but that does not seem to work either.

is there any other way to circumvent the upload_max_filesize default settings?

I looked and it seems that the post_max_size is set to 8MB, but that does me little good if the upload_max_filesize is still set at 2MB...

Any ideas?

#2 markbett

markbett
  • Members
  • PipPipPip
  • Advanced Member
  • 133 posts

Posted 18 September 2006 - 05:33 AM

umm try setting your php.ini file

#3 Daniel0

Daniel0
  • Staff Alumni
  • Advanced Member
  • 11,956 posts

Posted 18 September 2006 - 05:54 AM

Did you put a hidden MAX_FILE_SIZE field in your form?

#4 ci5ic

ci5ic
  • New Members
  • Pip
  • Newbie
  • 5 posts

Posted 18 September 2006 - 03:16 PM

umm try setting your php.ini file


If you read my post, you would notice that I do not have access to the php.ini file. I'm not the owner of the server.

I did not put a MAX_FILE_SIZE field in my form, simply because it would be unnecessary. I don't plan to limit the filesize because the only files that will be uploaded are MP3's, and I don't expect any of my band members (the only people that will be authorized to upload) will take advantage of this. Plus, at this point, I'm just trying to get it to work for files larger than 2MB, not really concerned about limiting the max upload size yet...

I thought that using PHP's ftp_put would work, but I can't seem to get that to work at all, regardless of file-size.

#5 Orio

Orio
  • Staff Alumni
  • Advanced Member
  • 2,491 posts

Posted 18 September 2006 - 03:23 PM

Maybe you could give them FTP access so they can upload these files directly...?

Orio.
Think you're smarty?

(Gone until 20 to November)

#6 ci5ic

ci5ic
  • New Members
  • Pip
  • Newbie
  • 5 posts

Posted 18 September 2006 - 03:55 PM

Maybe you could give them FTP access so they can upload these files directly...?

Orio.


The thought had crossed my mind, but most of them are not as tech saavy as I'd like them to be, and that's kinda what I was hoping to accomplish with PHP's ftp functions. Just want them to be able to upload, not give them access to all the other stuff I have out on the server...

#7 ci5ic

ci5ic
  • New Members
  • Pip
  • Newbie
  • 5 posts

Posted 18 September 2006 - 06:27 PM

Oh, and also making a .htaccess file does not work for me either. this is another function that has been turned off by my hosting company.

Am I S.O.L.?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users