Jump to content

Archived

This topic is now archived and is closed to further replies.

trillion

gd library error

Recommended Posts

I have been trying to install gd library on my server

I finally got it to work and all command line test were successful

gd library still not work with php though

php.ini gd line is incommented

as per http://www.phpfreaks.com/tutorials/105/0.php

I did [b]php -m[/b] on the command line and get:

[b]PHP Warning: Unknown(): Unable to load dynamic library './php_gd2.dll' - (null) in Unknown on line 0[/b]

How can I fix this and get gd library working with php?

Share this post


Link to post
Share on other sites
What is the extension_dir setting set to in the php.ini? And where is you php.ini located to?

if the extension dir is set to [b]./[/b] you'll have to setup the extension dir. So change to ./ to the full path where your php extensions folder is, for example if you installed php in the root of the hard drive, then the location to the extension folder would be: [b]C:/php/ext[/b] - (NOTE: if you have php4 you'll want to use [b]C:/php/extensions[/b])

When you ahve setup the extension_dir save the php.ini and restart your server.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.