Jump to content


Photo

php cant see mysql?


  • Please log in to reply
9 replies to this topic

#1 source_unknown

source_unknown
  • Members
  • PipPip
  • Member
  • 16 posts

Posted 22 September 2006 - 10:10 AM

Hey all Im having a bit of a problem. I have installed php5 and mysql succsessfuly but when I run phpBB instalation it tells me that I havent configured my database. Help would be apriciated. Pics below.

Posted Image

Posted Image

Posted Image

#2 steveclondon

steveclondon
  • Members
  • PipPipPip
  • Advanced Member
  • 161 posts

Posted 22 September 2006 - 11:02 AM

if this is a testing server you might try to download http://www.wampserver.com/en/ this will install php 5 along with mysql all in one go very easy on windows. It is quicker than me trying to go through it all

#3 steveclondon

steveclondon
  • Members
  • PipPipPip
  • Advanced Member
  • 161 posts

Posted 22 September 2006 - 11:05 AM

oh and this also installs apache as well so everything you need all working. + if you want you can also add php 4 and switch between the two which is handy for doing some work

#4 radalin

radalin
  • Members
  • PipPipPip
  • Advanced Member
  • 179 posts

Posted 22 September 2006 - 11:39 AM

Are you sure that you have selected right db type for the phpBB. it can occur problems.

Or check your php.ini file if the php_mysql or php_mysqli is enabled.

I recommend using wamp too. I have also configured my pgsql on wamp and It's really easy if you are a new to php. But most of the experienced will not recommend you installing wamp (not because they are only experienced:) because your developement environement should be like your real time server. And this pre made installers are not that good.

But try Zend Platform too. It's free for developers and very very easy.
Roy Simkes
Yet Another Parkyeri Developer

#5 source_unknown

source_unknown
  • Members
  • PipPip
  • Member
  • 16 posts

Posted 22 September 2006 - 12:36 PM

Yer the db type is set to 4/5  I have 5.

This is the error I get from phpmyadmin. I need to change something in the .ini but I dont know what.

Posted Image

#6 radalin

radalin
  • Members
  • PipPipPip
  • Advanced Member
  • 179 posts

Posted 22 September 2006 - 12:54 PM

in the ini file find "extension=php_mysql.dll" and enable it by removing the semi colon (;) before it.
Roy Simkes
Yet Another Parkyeri Developer

#7 AdRock

AdRock
  • Members
  • PipPipPip
  • Advanced Member
  • 911 posts

Posted 22 September 2006 - 12:55 PM

i installed WAMP seperately using this tutorial

http://www.puremango.../cm_wamp_97.php

I downloaded phpMAdmin and installed using this tutorial

http://www.ubbcentra...PhPMyAdmin.html

I haven't had any problems using these 2 tutorials and it all works perfectly
If your topic has been solved, please mark the topic as SOLVED.

This helps others from identifying which topics need help still

#8 Daniel0

Daniel0
  • Staff Alumni
  • Advanced Member
  • 11,956 posts

Posted 22 September 2006 - 01:06 PM

Did you absolutely have to post all of those images? >:(

You could at least have posted thumbnails that linked to the full-sized image.

#9 source_unknown

source_unknown
  • Members
  • PipPip
  • Member
  • 16 posts

Posted 22 September 2006 - 02:16 PM

It works fine now, thanks for the help.  One last thing.

My sites is  www.########.com  so when I go to my site it opens the index.html file. Thats what it is sposed to do... I dont want my site anymore I just want my phpbb forum.  I dont know how to tell apache that I dont want to open a index.html  I want it to open a index.php file.  How do i tell apache because even if I set my root to /phpbb it opens all the .php files    like config.php and help.php  but in a hirachy type thing. I just dont want to keep going to www.*******.com/phpbb2/index.php

#10 AdRock

AdRock
  • Members
  • PipPipPip
  • Advanced Member
  • 911 posts

Posted 22 September 2006 - 04:50 PM

in you httpd.conf file look for this

<IfModule mod_dir.c>
    DirectoryIndex index.html index.php
</IfModule>

then just take out index.html
If your topic has been solved, please mark the topic as SOLVED.

This helps others from identifying which topics need help still




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users