Jump to content


Photo

upload_max_filesize


  • Please log in to reply
1 reply to this topic

#1 neddy

neddy
  • New Members
  • Pip
  • Newbie
  • 6 posts

Posted 22 September 2006 - 11:13 PM

i search the forum before posting and couldnt find a solution that works

first off i cannot change my php.ini, because my host doesnt allow me to.. ive requested it to be changed, but no reply yet, and i read somewhere hosts dont like changing it..

anyway im on linux hosting and my phpinfo says Server API - CGI so im guessing its the cgi version of php (?)

ive tried adding the changes to a .htaccess file and get a 500 error, but then read later that it doesnt work on the cgi version of php..

now ive read that i can make another php.ini in my webs root and add upload_max_filesize = 10M to it but that makes other things on my site not work... i dont change anything other then upload the php.ini

is there anywhere in the phpinfo that will tell me that a new php.ini wont work? im thinking the servers reading it but not working properly... but im completly confused  ???

also is there a setting i can stick in the new php.ini that will tell me if the new php.ini is working without causing to much hassle?

cheers
Neddy

EDIT: even if i upload an empty php.ini other parts of my site stop working properly...
EDIT2: ive added all the settings that can be changed by PHP_INI_PERDIR

session.use_trans_sid = 0
zlib.output_compression = 0
allow_call_time_pass_reference = 1
asp_tags = 0
magic_quotes_gpc = 1
output_buffering = 0
output_handler = NULL
register_argc_argv = 1
register_globals = 1
short_open_tag = 1
arg_separator.input = &
auto_append_file = NULL
auto_prepend_file = NULL
upload_max_filesize = 10M
post_max_size = 15M
always_populate_raw_post_data = 0

and my pages seem to be working properly but that doesnt change the upload_max_filesize  ???

#2 markbett

markbett
  • Members
  • PipPipPip
  • Advanced Member
  • 133 posts

Posted 23 September 2006 - 12:54 AM

check your hosts FAQ's normally they will give you proper settings when creating this file




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users