Jump to content


Photo

Php mysql connection


  • Please log in to reply
6 replies to this topic

Poll: how to connect php 4.1.1 and mysql5.0 (0 member(s) have cast votes)

how to connect php 4.1.1 and mysql5.0

  1. yes (0 votes [0.00%])

    Percentage of vote: 0.00%

  2. no (0 votes [0.00%])

    Percentage of vote: 0.00%

Vote Guests cannot vote

#1 jana

jana
  • Members
  • PipPipPip
  • Advanced Member
  • 35 posts
  • LocationIndia

Posted 25 September 2006 - 10:41 AM

i have installed phptriad and mysql 5.0 when i tried to connect. it gives me the error message that.\

Warning: Client does not support authentication protocol requested by server; consider upgrading MySQL client in c:\apache\htdocs\testconnec.php on line 2.



and my src was simple

$connec=mysql_connect('localhost', 'root', 'pwd')
or die("cannot connect to MySQL");



can any one helpme to solve this problem.
Jana

#2 trq

trq
  • Staff Alumni
  • Advanced Member
  • 31,041 posts

Posted 25 September 2006 - 10:57 AM

Correct me if Im wrong but doesn't phptriad come with MySql? There is no need to install it seperately. What you have here is a compatability issue between your versions of php and mysql.

#3 jana

jana
  • Members
  • PipPipPip
  • Advanced Member
  • 35 posts
  • LocationIndia

Posted 25 September 2006 - 11:25 AM

at present phptriad is having phpversion 4.1.1 can i replace it with php5.1.6.
Jana

#4 wildteen88

wildteen88
  • Staff Alumni
  • Advanced Member
  • 10,482 posts
  • LocationUK, Bournemouth

Posted 25 September 2006 - 11:28 AM

The version of PHP4 you have is out of date. As the latest version of PHP4 is PHP4.4.4. However I'd recommend you to do awayt with using any all-in-on package. And install AMP seperately.

#5 jana

jana
  • Members
  • PipPipPip
  • Advanced Member
  • 35 posts
  • LocationIndia

Posted 25 September 2006 - 02:21 PM

can anyone tell me how to configure apache server 2.2.3 with php 5.1.6 and mysql 5.0server manually?

Jana

#6 trq

trq
  • Staff Alumni
  • Advanced Member
  • 31,041 posts

Posted 25 September 2006 - 02:22 PM

What steps have you taken so far? Are they installed? Have you read each applications installation instructions?

#7 jana

jana
  • Members
  • PipPipPip
  • Advanced Member
  • 35 posts
  • LocationIndia

Posted 25 September 2006 - 02:31 PM

yes i have installed phptriad and mysql5.0 server. but i hav created a table in mysql server5.0 when i try to connect to the server i got the error msg that i hav posted. can u tell me what amp to be used.
Jana




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users