Jump to content

Archived

This topic is now archived and is closed to further replies.

djcasp

php-gtk2 installation

Recommended Posts

I can't tell if php-gtk2 is installed on my system.  i followed the directions from gtk.php.net and tried it with and without specifying the location of phpize and php-config.  no errors were thrown during the build and the make.  i'm running php 5.1.2(cli) on ubuntu dapper.  running php -m | grep php-gtk doesn't returning anything. i've enabled the extension in php.ini  (extension=php_gtk2.so)  any ideas about this? i need to have this up and running to get my project going.
thanks much
btw hope this is the correct forum

Share this post


Link to post
Share on other sites
[quote author=djcasp link=topic=109644.msg442156#msg442156 date=1159327092]
I can't tell if php-gtk2 is installed on my system.  i followed the directions from gtk.php.net and tried it with and without specifying the location of phpize and php-config.  no errors were thrown during the build and the make.  i'm running php 5.1.2(cli) on ubuntu dapper.  running php -m | grep php-gtk doesn't returning anything. i've enabled the extension in php.ini  (extension=php_gtk2.so)  any ideas about this? i need to have this up and running to get my project going.
thanks much
btw hope this is the correct forum
[/quote]

The "php_gtk.so" file should should also be put in the directory listed as the "extension_dir" in your php.ini. There are demos in the "demos" directory that you can try running afterwards.

Share this post


Link to post
Share on other sites
thanks much i needed to add the php_gtk2.so to the php.ini in my CLI folder not my apache2 folder and then specify the location of the extension dir.  in a follow up question where would i change what directory apache looks in for php.ini? right now its looking in my cli folder and i would like to change that if possible.  thanks for your help.

Share this post


Link to post
Share on other sites
[quote author=djcasp link=topic=109644.msg442746#msg442746 date=1159398321]
thanks much i needed to add the php_gtk2.so to the php.ini in my CLI folder not my apache2 folder and then specify the location of the extension dir.  in a follow up question where would i change what directory apache looks in for php.ini? right now its looking in my cli folder and i would like to change that if possible.  thanks for your help.
[/quote]

If you're using Apache 2 you can use the "PHPIniDir" directive to change it.

httpd.conf
[code]
PHPIniDir "/path/to/dir/"
[/code]

You can also recompile. ie reconfigure with "--with-config-file-path=/path/to/dir".

Setting the environment variable PHPRC should also be an option, but I haven't gotten it to work.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.