Jump to content

Archived

This topic is now archived and is closed to further replies.

Luke Beale

Version Problem Need Help...

Recommended Posts

Hello,

I am trying to import a .sql file from my old host to my new host but the old host is not the same version of mysql that the new host is using.

Old host mysql version: 4.1.21
New host mysql version: 4.0.27

Is there a way for me to conver the sql file from 4.1.21 to 4.0.27?

Share this post


Link to post
Share on other sites
The sql file should still work. Strange why your host has downgraded mysql to 4.0.27

Share this post


Link to post
Share on other sites
[quote author=wildteen88 link=topic=109850.msg443169#msg443169 date=1159461866]
The sql file should still work. Strange why your host has downgraded mysql to 4.0.27
[/quote]

No the file will not work as i am moving hosts.
So the new host has a different version of mysql from the old host and so it wont allow me to put it into the database of the new host.

Its a vbulletin backup of my forum (the sql file).

Share this post


Link to post
Share on other sites
Do you get any errors at all. Prehaps have a word with your host. Se if they can update MySQL or see if they can get your sql file to work.

Share this post


Link to post
Share on other sites
[quote author=wildteen88 link=topic=109850.msg443174#msg443174 date=1159462745]
Do you get any errors at all. Prehaps have a word with your host. Se if they can update MySQL or see if they can get your sql file to work.
[/quote]

I have asked them and they said they can not get it to work because of the sql file and their databases are different versions.

I use big dump to try to import the 11 meg database file & the error i got was

"You have an error in your SQL syntax. 'DEFAULT CHARSET=latin1' at line 13"

Which i think had something to do with the different database versions.

Share this post


Link to post
Share on other sites
Use DEFAULT CHARACTER SET instead... there are a bunch of things like this.

Share this post


Link to post
Share on other sites
[quote author=fenway link=topic=109850.msg443208#msg443208 date=1159468392]
Use DEFAULT CHARACTER SET instead... there are a bunch of things like this.
[/quote]

Sorry i dont understand.

Share this post


Link to post
Share on other sites
Basically open up the .sql file into a text editor such as wordpad. if you use ntoepad it may become unstable and crash the system.

Now find any matches regarding:
DEFAULT CHARSET=latin1

and change it to DEFAULT CHARACTER SET=latin1

Share this post


Link to post
Share on other sites
I did what you said and i got this error.

Error at the line 14: ) ENGINE=MyISAM AUTO_INCREMENT=4 DEFAULT CHARACTER SET=latin1;

MySQL: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARACTER SET=latin1' at line 13

Share this post


Link to post
Share on other sites
Try doing away with the default charset. SO remove anything matching [i]DEFAULT CHARACTER SET=latin1[/i]

Share this post


Link to post
Share on other sites
[quote author=wildteen88 link=topic=109850.msg443227#msg443227 date=1159470419]
Try doing away with the default charset. SO remove anything matching [i]DEFAULT CHARACTER SET=latin1[/i]
[/quote]

now im getting an error to do with one of the tables of the forum.

"Error at the line 30: INSERT INTO `vbaccess` VALUES (11, 4, 1);"

There must be a easier way of doing this or something

Share this post


Link to post
Share on other sites
You crossed versions, there are incompatabilities... especially since the dump didn't contain complete inserts.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.