Jump to content

Archived

This topic is now archived and is closed to further replies.

kostakondras

500 - Internal Server Error (installing Zend Framework)

Recommended Posts

I'm currently going through the process of installing the Zend framework and I have created a new project. However when viewing the public folder I am greeted with an Internal Server Error.

 

Any idea on what could be causing this problem? I have looked through the FAQ on ZendFramework website and Google to no avail.

 

Also I have included a screencast in the link below to give you an idea of where I'm currently at if it helps at all.

http://screenr.com/N2Y

 

Thank you for any help.

Share this post


Link to post
Share on other sites

I'd guess it was a path problem, given that you're just setting it up.  Take a look at the path setup in /public/index.php, the location of both the application folder and the library folder are in there, verify that they are correct.

 

Another thing, I've not seen an include_path setup using multiple include_path's in the php.ini file, I'm not sure if that would cause any problems.  A single directive with all your folders separated by a semicolon is typical, such as include_path=".;c:\wamp\libraries\Zend;c:\wamp\pear;c:\wamp\libraries\smarty"

 

Third thing, just to clear you up on it, the Zend folder within the library folder from the Zend installation archive is the correct one to include, you seemed hesitant about it in your video.  Everything else are extras, experimental modules, docs, unit tests, et cetera.

 

A troubleshooting and debugging tip, check Apache's error log and PHP's error log for more descriptive errors.  The logs are typically in their perspective directories <Apache Dir>\logs and <PHP Dir>\log.

Share this post


Link to post
Share on other sites

Thanks thehippy. I've recently upgraded my PHP on WAMP and it's now running at PHP 5.3.0. I've noticed the shortcut to edit the PHP.ini file from the Desktop is not the php.ini file that resides inside c:\wamp\bin\php\php5.3.0. But even after changing the include_path in this folder, still, the includes are not registering.

 

What would the reason be. I'm restarting the server every time I do it. Here is the code (I've put an echo statement into one of the Zend files and included it with require_once.

 

include_path = ".;c:\php\includes;C:\wamp\zend\library\Zend"

 

I restart the server and I have a statement in a test php file that states the following:

 

require_once("View.php"); //as you know this is some file inside the zend/library/Zend folder

 

Why doesn't it work? And why are there multiple PHP.ini files.

Share this post


Link to post
Share on other sites

I'm a bit of a tard, don't tell anyone though.  You should be including the folder that contains the Zend folder, such as C:\wamp\zend\library\.  Your book probably has includes such as require_once('Zend/Version.php');  ... not sure that's your problem atm, but it might be.

 

A warning to you I manually setup Apache, PHP and the RMDB I'm using so I don't have any experience with the bundled installers and how they manage things.  For which php.ini you should be editing, its entirely based upon the situation.  From the command line PHP uses the one in its own directory, or the first one found in PATH.  When you're using Apache2 the php.ini that gets used is the one configured with the PHPIniDir.  The quickest thing to do would be to create a simple <?php phpinfo(); ?> script to see what's going on.

 

My simple zftest.php file for testing a zend framework install.

<?php
require_once('Zend/Version.php');

echo "Zend Framework Installed Version: " . Zend_Version::VERSION;
echo "<br /> Zend Framework Latest Version: " . Zend_Version::getLatest();

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.