Jump to content

Archived

This topic is now archived and is closed to further replies.

a4avaiz

Cant get contact form to send mail! SMTP settings driving nuts!

Recommended Posts

Hello. I am new to SMTP and not sure exactly how it works.

Basically, I have a Win2003 box running Apache. It hosts a community website I made for my school (www.iit.edu) and they have provided a subdomain as our address (xxxxxx.iit.edu)

I have made a contact form, but when i give submit, it gives the warning [code]Failed to connect to mailserver at "students.iit.edu" port 25, verify your "SMTP" and "smtp_port" [/code]. I want the details from the users to me mailed to my IIT email account.

according to IIT, our smtp address is students.iit.edu.i have no idea why it was not working. then I did a search in php freaks before i started this thread. i found this [url=http://www.phpfreaks.com/forums/index.php/topic,99143.0.html]http://www.phpfreaks.com/forums/index.php/topic,99143.0.html[/url] post, i got an idea of whats going on but couldnt fix the problem. I also went ahead and installed a SMTP server (do i need that?).  I ran the same contact form home from my laptop(localhost) using my ISP's SMTP address and it worked. But I am unable to run the form from the server.

I know I have a router thats forwarding all the requests to my server. Does it play a role in the SMTP settings?. Can anyone give me an idea which address so i have to put exactly in the SMTP field of the php.ini file?. I am way confused. And how would i configure the SMTP server if i needed it.

Would really appreciate any reply so that I can try out something. Thanks in advance!

Share this post


Link to post
Share on other sites
If they have a router setup with forwarding, they'll need to make sure they're forwarding traffic for TCP Port 25.  Normally if it's just a website they'll forward TCP Port 80.  This would cause a failure to connect.

HTH

Dest

Share this post


Link to post
Share on other sites
please tell me what do i do? whats the other way around? ive tried to set the smtp port to 80, but doesnt connect...

thanks..

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.