Jump to content

Archived

This topic is now archived and is closed to further replies.

cjboston

retro fitting database

Recommended Posts

i have rss feed display script.it worked fine in a mysql 4.1. when i tried to upload the dump to a 4.0 it gave me the error :
[color=blue]#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=latin1' at line 4[/color]
How do i retro fit the dump

[color=red]--------------------------------------------------------

--
-- Table structure for table `config`
--

CREATE TABLE `config` (
  `name` varchar(30) NOT NULL default '',
  `value` text NOT NULL
) ENGINE=MyISAM DEFAULT CHARSET=latin1;

--
-- Dumping data for table `config`
--


-- --------------------------------------------------------

--
-- Table structure for table `feed`
--

CREATE TABLE `feed` (
  `feedid` bigint(20) NOT NULL auto_increment,
  `uid` varchar(20) NOT NULL default '',
  `tplindex` bigint(3) NOT NULL default '1',
  `url` text NOT NULL,
  PRIMARY KEY  (`feedid`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1 AUTO_INCREMENT=15 ;

--
-- Dumping data for table `feed`
--

INSERT INTO `feed` VALUES (1, 'admin', 1, 'http://news.google.com/news?hl=en&ned=us&q=outer+space&ie=UTF-8&output=rss');

-- --------------------------------------------------------

--
-- Table structure for table `tpl`
--

CREATE TABLE `tpl` (
  `tplindex` bigint(20) NOT NULL auto_increment,
  `name` varchar(30) NOT NULL default '',
  `fname` varchar(100) NOT NULL default '',
  PRIMARY KEY  (`tplindex`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1 AUTO_INCREMENT=2 ;

--
-- Dumping data for table `tpl`
--

INSERT INTO `tpl` VALUES (1, 'Default Skin', 'default.tpl');

-- --------------------------------------------------------

--
-- Table structure for table `user`
--

CREATE TABLE `user` (
  `uid` varchar(20) NOT NULL default '',
  `upass` varchar(20) NOT NULL default '',
  `email` varchar(255) NOT NULL default '',
  PRIMARY KEY  (`email`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1;

--
-- Dumping data for table `user`
--

INSERT INTO `user` VALUES ('admin', 'admin', 'adMIN@gmarketingsolutions.com');
INSERT INTO `user` VALUES ('saire', 'a', 'biznis@yahoo.com');[/color]

Thanks,
    CJ Boston
    [url=http://www.profitextreme.biz/][color=purple]web site promotion[/color][/url]

Share this post


Link to post
Share on other sites
Change the last line of each of the table definitions to remove the charset reference. You may also have to change ENGINE to Type.  That usually works for me when I transfer stuff between hosts with different versions of stuff.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.