Jump to content


Photo

Admin log in / restrict access to page


  • Please log in to reply
7 replies to this topic

#1 kevdotbadger

kevdotbadger
  • Members
  • PipPip
  • Member
  • 18 posts

Posted 06 May 2005 - 07:53 PM

i use the automatated scripts within dreamweaver, the login on works but th rscrit access doesnt so is thre tuts on the internet to handcode this?

#2 toplay

toplay
  • Staff Alumni
  • Advanced Member
  • 973 posts

Posted 06 May 2005 - 08:46 PM

I don't know what the those scripts are. I moved your post to a more suitable topic area. Try and be more specific of what you want.

#3 dmarchman

dmarchman
  • Members
  • PipPip
  • Member
  • 12 posts

Posted 27 May 2005 - 07:33 PM

It's a known-by-macromedia bug that the restrict assess to page server behavior doesn't work right because it doesn't use globals to store the session. There are a few fixes out there, but for some reason macromedia hasn't addressed this theirselves. I found one workaround in the book: PHP Dreamweaver MX 2004 (Apress ISBN 1-59059-350-2), but while the fix worked fine on my test server, it didn't work on my webhost. I eventually turned to another script after searching for one that explained itself simply.

I still don't understand why macromedia won't fix this. Hell, they updated to 7.01 to fix numerous bugs and even added back in the godawful timeline panel that NOBODY uses.

#4 Akinraze

Akinraze
  • New Members
  • Pip
  • Newbie
  • 7 posts

Posted 06 June 2005 - 03:06 AM

I eventually turned to another script after searching for one that explained itself simply.



What was the script you turned to?

I am having the same problems now.

#5 dmarchman

dmarchman
  • Members
  • PipPip
  • Member
  • 12 posts

Posted 07 June 2005 - 06:28 AM

i found this:

Clicky clicky

i used the version that stores my username and password in the login page since i'm the only one who accesses my admin area.

What was the script you turned to?

I am having the same problems now.

View Post



#6 geo__

geo__
  • New Members
  • Pip
  • Newbie
  • 1 posts

Posted 07 June 2005 - 03:06 PM

I 've spent the last8 hours trying to solve this bug. I tried both on apache and IIS and no luck! I am so pissed that I am thinking of turning to adobe golive.
The whole point of using dreamweaver is not to use other scripts. If I was to use other scripts I may as well not use Dreamweaver at all. The code it produces is almost unreadable.

It's a known-by-macromedia bug that the restrict assess to page server behavior doesn't work right because it doesn't use globals to store the session. There are a few fixes out there, but for some reason macromedia hasn't addressed this theirselves. I found one workaround in the book: PHP Dreamweaver MX 2004 (Apress ISBN 1-59059-350-2), but while the fix worked fine on my test server, it didn't work on my webhost. I eventually turned to another script after searching for one that explained itself simply.

I still don't understand why macromedia won't fix this. Hell, they updated to 7.01 to fix numerous bugs and even added back in the godawful timeline panel that NOBODY uses.

View Post



#7 Akinraze

Akinraze
  • New Members
  • Pip
  • Newbie
  • 7 posts

Posted 08 June 2005 - 12:50 AM

after what dmarchman said about this being a well know problem, i was so ticked i could have spit bullets, so I headed on over to macromedias site and after several pages of searching I ran accross this article/tutorial http://www.macromedi...h_users_08.html

Copy paste from the bottom of the page:

Note: PHP users with PHP 4.2 and higher will be disappointed to learn that instead of being redirected to the originally requested page after log-on, the application sends them to the home page. The reason for this is that the server behavior that is supposed to cause the redirection to the originally requested page relies on a configuration setting, register_globals, that must be on for redirection. Since PHP 4.2, the default setting for register_globals is off. You can go into your php.ini file and change it to on and the site will work as expected. However, it was turned off for a reason—this setting creates a potential security hole in PHP. Thus, before you decide to go into php.ini and change the setting, I recommend that you research the issue on the web.


in my case, this IS the issue, I am sure the ISp that houses my site won't concider changing this setting so I didn't change it on mine to verify (but probably should just for sake of knowing for sure).

I installed 5.0.4 on my system for production and went into the my php.ini and sure enough: register_globals = Off, s i think I can pretty much say that this IS the problem, I think I will focus on studying the tutorials here on the site to get mine working now.

goodluck!

#8 Akinraze

Akinraze
  • New Members
  • Pip
  • Newbie
  • 7 posts

Posted 09 June 2005 - 11:48 PM

solution found here: http://friendsofed.i...165&m=324102421




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users