Jump to content

Archived

This topic is now archived and is closed to further replies.

warewolfe

IE rendering of php pages

Recommended Posts

Due to a series of hardware failures I've recently had to do a full reinstall of my system (Win Xp) and took the chance to upgrade to the latest stable versions of Apache2.2, PHP5, and Mysql4.1.
  After installation and testing I'm getting the strangest behaviour when I check out any local page with a php extension.

Sympton 1) Treats any attempt to open a local php page as a "file download" (works ok for online pages)

Sympton 2) If I go to any other page with javascript it comes up with a "information bar" saying that it's blocked some content, if I allow the content I can then use the browser to look at local php pages. But it won't use include files.

  This behaviour is not replicated when I check out the same pages using FireFox. Everything works fine in FF.
 
  Any help or hints would be appreciated.

WW

Share this post


Link to post
Share on other sites
For symtopm 2 it sounds like you are browsing the file via Windows Explorer (double clicking the file to view it in IE) rather than going to http://localhost/ to view the file. This is the default behaviour of IE6 SP2 when you view html files with javascript when you view them locally.

For your first symtom it appears you have not configured Apache correctly. Make sure you have added PHP as an Apache Module or as CGI and that you restarted the Apache server when you have made any changes to any configuration files (httpd.conf, php.ini).

NOTE: Currently PHP is not compatible with Apache2.2.x, unless you have PHP5.2 or are using third party dll files. I'd suggest you downgrade Apache to Apache2.0.x instead.

Share this post


Link to post
Share on other sites
Thanks for the reply,
  Found the answer myself but you kinda right for symptom two. For others who have similar problems (I found a couple of similar complaints when I googled the symptoms)
 
The problem was how I was calling the local php generated page. I was calling it from C:\Apache2.2\htdocs\MyWebDir\index.php instead of http:\\localhost\MyWebDir\index.php and so IE treated the page as an intranet generated file rather than a local file.

  Once I had changed that everything was fixed.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.