Jump to content

Archived

This topic is now archived and is closed to further replies.

clem_c_rock

fopen causing permission errors on IIS

Recommended Posts

Hello,

I'm trying to find out how to set the file permissions on an IIS server so I can execute file handling functions such as fopen, fputs, fclose ect.


I know this is pretty basic but I've yet to find a solution.

thanks for your help!

Clem C

Share this post


Link to post
Share on other sites
PROBLEM SOLVED!

The problem was that I was trying to grant the security permissions through IIS manager instead of simple old explorer.  I just had to grant the default web viewing (in our case: IUSR_WW251)  group permissions to the folder where the scripts were being read.

Here's what I did:

Windows Explorer >> Parent folder where scripts are reading/writing to files >> Sharing and Security >>
Security tab >> Add >> Advanced >> Find Now >> choose default web user (IUSR_WW251) >> OK >> OK

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.