Jump to content

Disabling session.auto_start for a single directory only


BoarderLine

Recommended Posts

After installing SquirrelMail I am facing the following error on initial start up.

 

SquirrelMail 1.4.x is not compatible with PHP's session.auto_start setting. Please disable it at least for the location where SquirrelMail is installed.

 

Now my problem is not how to turn session.auto_start off (php.ini) as I really don't want to.  Does any one know how I can go about turning it off for the squirrelmail directory only??

 

Many Thanks

Link to comment
Share on other sites

There's no good reason to have session.auto_start on in the first place.

 

You would need to tell us how php is integrated with the web server and which web server you are using. Is php running as an Apache Module or as a CGI application?

Link to comment
Share on other sites

Yes, it prevents you from changing or configuring any of the session settings in a script (which is probably why SquirrelMail won't work) and it prevents you from doing things like using OOP/classes in session variables (which also might be the reason SquirrelMail won't work.)

 

You should be able to put php settings into a .htaccess file in the folder in question.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.