Jump to content

IIS7 Timeout/Error/?


Davez69gto
 Share

Recommended Posts

This is kind of an odd issue. 

Background:

    I have an application on an IIS 7 Server that when it runs it contacts two different databases.  It first grabs roughly 27k rows from an oracle server, parses them and inputs them into a mssql database while also returning a csv file. 

Problem

    After using this program for weeks on end it all of the sudden stopped working.  I moved the exact files over to a different IIS 7 server and everything worked great.  I then moved the files to a different folder on the server it usually runs on and everything worked file.  The then copied and renamed the folder it resides in to find that it still works as a child of the same parent. 

Question

    Can you think of anything that would make my application stop working but work if it is in other directories.  It only uses relative links within the program... 

A Thought

    Is there a cache in IIS 7 that could fill up for a particular page.  This file ends up being around 2mb a pop and it is created on the fly so does the server try and store the data till it gets to a certain size then after that fail out.  Then moving to a new directory would break that link and make it think that this is a new file and starts the cache all over again? 

 

Any help would be appreciated.

Dave

Link to comment
Share on other sites

It appears that I have fixed the problem...

 

Solution(believed): I increased the amount of memory a php script can use from 128 to 256.  I was running a similar script and turned on all the errors and warning and it said that it was at 128 and was trying to get 8 more mb.  After I increased the memory that script worked just fine.  I then checked the script that I was talking about above and it seemed to work in both directories (old and new).  This leads me to believe that when the application or script is run in one directory vs another it uses less memory.  Is this possible? 

 

I want to give it a week before I consider it completely fixed...

Link to comment
Share on other sites

This thread is more than a year old.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.