Jump to content

Archived

This topic is now archived and is closed to further replies.

Bloodvayne

Export/Import problem....

Recommended Posts

I am a n00b when it comes to MySQL. So I am pretty sure I came to the right place for this.  :D

Anywho.

Me and a buddy are straight up stuck trying to Export his database_name_here.sql file from his database on another server to my webserver. We bother are using the same phpMyAdmin control panel for this task.

It is for the Sedito Engine.

The problem I see is this:

[code] SQL query:

-- phpMyAdmin SQL Dump
-- version 2.9.0.2
-- http://www.phpmyadmin.net
--
-- Host: localhost
-- Generation Time: Oct 12, 2006 at 08:20 PM
-- Server version: 5.0.24
-- PHP Version: 4.4.2
--
-- Database: `db181315901`
--
-- --------------------------------------------------------
--
-- Table structure for table `sed_auth`
--
CREATE TABLE `sed_auth` (
`auth_id` mediumint( 8 ) NOT NULL AUTO_INCREMENT ,
`auth_groupid` int( 11 ) NOT NULL default '0',
`auth_code` varchar( 24 ) NOT NULL default '',
`auth_option` varchar( 24 ) NOT NULL default '',
`auth_rights` tinyint( 1 ) unsigned NOT NULL default '0',
`auth_rights_lock` tinyint( 1 ) unsigned NOT NULL default '0',
`auth_setbyuserid` int( 11 ) unsigned NOT NULL default '0',
PRIMARY KEY ( `auth_id` ) ,
KEY `auth_groupid` ( `auth_groupid` ) ,
KEY `auth_code` ( `auth_code` )
) ENGINE = MYISAM DEFAULT CHARSET = latin1 AUTO_INCREMENT =541

[/code]

MySQL said: Documentation
#1064 - You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=latin1 AUTO_INCREMENT=541' at line 30


All help will be appreciated. We are both  ??? and  :-\

Thanks,
Scott Miller

Share this post


Link to post
Share on other sites
I would guess that although it's the same phpmyadmin version, it's a different mysql version.  Try deleting some things around where the error is.  I would try deleting "default" first.. then try removing "charset = latin1".  With enough mangling I'm sure it will start working :)

Share this post


Link to post
Share on other sites
Yeah, different version... drop it, or use CHARACTER_SET, or something similar; I don't remember.

Share this post


Link to post
Share on other sites
Hey!! That did it. I removed each line that had "DEFAULT CHARSET = latin1" and it then allowed me to import it. I am waiting for him to get back to me and see if it now runs off my server. If not I add the lines back and will try that "CHARACTER_SET" and see if it will still let me import that. Then try it again.

Thanks a million.

At first I was thinking it was my host... phew *wipes head*

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.