Jump to content

Archived

This topic is now archived and is closed to further replies.

jagguy

configure cgi

Recommended Posts

Hi,

I have apache 2.0.55 ,winxp and active perl 5.88.

The instructions for installing this on apache to run cgi scripts are confusing to say the least.

my http.conf has these changes to run cgi scrips on my c:/www/cgi-bin directory . It does run html/php no problems.

In httpd.conf I add

<Directory "C:/www/cgi-bin">
Options ExecCGI
AllowOverride None

</Directory>

AddHandler cgi-script .cgi .pl

I run the below file (which runs on the command line so perl is installed properly) and I get a 404 not found error on the webpage on http://localhost/cgi-bin/test.pl with the file in c:/www/cgi-bin

#!c:/perl/bin/perl.exe
print "Content-type: text/html\n\n";
print "Hello, World.";

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.