Jump to content


Photo

Upgrading MySql with XAMMP


  • Please log in to reply
1 reply to this topic

#1 HRH Ming

HRH Ming
  • New Members
  • Pip
  • Newbie
  • 1 posts

Posted 13 October 2006 - 05:18 PM

Hi, I installed XAMMP with Apache/2.0.52 (Win32), MySQL 4.1.8, PHP/5.0.3.  I want to use triggers but am told MySql 5.0 or above is needed.  Is there a simple way to upgrade? I know I can simply download the latest version of MySql but will this cause problems? Am not overly technical despite being able to develop.  Also. I have created an index on a primary key field, if I create an index on other fields will those indexes be non-clustered?

Thanks

HRH Ming


#2 fenway

fenway
  • Staff Alumni
  • MySQL Si-Fu / PHP Resident Alien
  • 16,199 posts
  • LocationToronto, ON

Posted 13 October 2006 - 07:31 PM

The MySQL refman has an list of "incompatible changes" associated with this version change; most are easy to work around, but you need to consult this list.
Seriously... if people don't start reading this before posting, I'm going to consider not answering at all.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users